Error with CPF 3.0 and Java


I don’t know if this is a CPF bug or mine but when i try to launch RapidMiner, which launches javaw.exe I get a message box with the message Could not create the java virtual machine. I tried to solve it using Google, no luck with the suggestions found, and finally i decided to uninstall CPF. RapidMiner (RapidMiner.exe) worked great without the annoying Could not create the java virtual machine message. So i tried to install CPF again, after all a firewall is always needed, and I tried to find a way to run RapidMiner.exe, and the only way found was make a change at the Defense+ security settings, just by simply checking the Deactivation option, but without rebooting.
Then I tried to make javaw.exe and RapidMiner.exe Trusted files, but the error persisted, so I decided to let it be and whenever i need RapidMiner I simply deactivate Defense+, launch it, and when it shows I Activate Defense+ again (all of this without rebooting, of course).
So, am I distracted and can this problem be solved or is this a bug?

Sorry for my English
Nuno Morgado