Error when trying to watch Netflix M7355-1203 [Merged]

Hi I’m using Comodo Dragon Beta Version on Windows 8.1 and I get error code M7355-1203 when I try to watch Netflix.
And I get the same error when trying Chromodo but Firefox is working perfectly and Google Chrome is working too.
Please forgive my bad English because English is my second language.
Mod edit: Added merged to the topic title, Captainsticks.

Hi and welcome jonteha,
The new versions of Chromodo and Dragon have disabled NPAPI plug-ins by default, before this it is most likely that you were using the Silverlight NPAPI plug-in.
Google Chrome has the ‘Widevine Content Decryption Module’, which is required for protected audio and video content and is not included with all alternative Chromium based browsers.

To resort back to using the Silverlight plug-in, you need to re-enable NPAPI support in your browser (Dragon or Chromodo).
A temporary workaround to enable NPAPI plugins is to type chrome://flags/#enable-npapi into the address bar and enter.
Select enable of the highlighted entry and relaunch the browser.

Note: The above workaround to enable NPAPI plugins will most likely be removed from version 45 and above (Estimate: September).

Your English is fine. :-TU

Kind regards.

I have the same issue, after following yoru steps and restarting the browser this did not fix the problem for me.

I am having the same problem - have tried the above steps and still get the same error message when trying to watch Netflix:

Error Code: M7355-1203

Since the Dragon 42 update, Netflix will not work, with error M7355-1203 stating: Netflix Video Player Unavailable We’re having trouble playing Netflix on your browser. Please make sure you are on an official version of Chrome.

Obviously Dragon is not an official version of Chrome, but Netflix worked just fine prior to this update.

Has anyone else been able to get Netflix working? Or is this a bug?

The update might have or more likely broke the plugin or how ever the software functions. 99.9% the reason. Give it a few days and report back.

I’m guessing in order to use Netflix you need to either use Silverlight or HTML5, I’m also guessing that Silverlight only supports NPAPI and not PPAPI, I’m also guessing that Netflix uses proprietary codecs and such that Comodo Dragon doesn’t support over HTML5.

I have the same Netflix error message (‘Error Code: M7355-1203’) before and after enabling NPAPI. Netflix works on all my other browsers, though.

Can’t seem to get it to play over silverlight on any browser. Looks like Netflix switched to HTML5 completely.

Hi Guys,
Merged topics.
I am also seeing if I can find out any information regarding this issue.


Hello everyone,
Unfortunately, Widevine CDM is not available in chromium right now. Many chromium and chromium based browser users suffer from this issue. Debianers are also uncomfortable with this situation, not to load WideVinew CDM PPAPI plugin into chromium. See 429452 - chromium - An open-source project to help move the web forward. - Monorail

What Chrome doing is not legal (edit: I think) right now, because Widevine CDM is PPAPI plugin that should be publicly installed. But installer from is not supporting Chromium.

The only workaround that we have and can provide is to install Silverlight plugin with enabling NPAPI support. I see that some of our users still have problems with this solution. Note that, Netflix recently changed its default video player to HTML5, you need to change it from HTML5 to Silverlight in your Netflix account settings.


Edit: I believe, I have to make it clear that why this issue is illegal in my opinion. Netflix is supposed to provide its service and its protected content through well known DRM vendors, such as Google (WideVine), Microsoft (PlayReady), Apple(FairPlay). Currently, there is no direct way for Chromium users in Linux to use Netflix service, who already paid for this service. The same situation is valid for all DRM protected contents, e.g. YouTube paid content. Google, deliberately or not, force users to use Chrome with these changes.

PPAPI was developed by them, a new PPAPI flash player plugin was developed with Adobe, they announced they’re not going to support NPAPI, and now they do not distribute Widevine CMD plugin which is also a PPAPI plugin, strictly required to display protected content…

If I understand rightly, Comodo may license Widevine Content Decryption Module for Dragon/Chromodo, without licensing fees.

But as Sanya mentioned, there is also a problem with proprietary audio and video formats not supported by Dragon/Chromodo. To support those natively, Comodo would have to pay licensing fees, but Dragon/Chromodo could also use the system’s decoders (like Opera), at least on Windows 7+.

Linux wasn’t officially supported by Netflix before, as there is no Silverlight for Linux. It became officially supported in October 2014.
Chrome isn’t the only Chromium-based option, as Opera 31 includes Widevine. Here is my score for Opera 31 on Ubuntu 15.04 (FFmpeg is required for proprietary audio and video formats): HTML5test - How well does your browser support HTML5?
Widevine could be licensed for Chromium too, for example by Canonical for Ubuntu, but (some) users wouldn’t want it to be installed by default, as its source code is not (and can not be) open.

I’ve been searching for a solution for days now! Only thing that’s worked is going back to an old version. I found v36 on my pc and it works. So, I’ll be keeping it around. I’ll keep Dragon and the latest version of it, but Chromium/Chromodo won’t be updated until something is figured out. This is a prob with Amazon Prime as well.

The crazy thing is Netflix and Prime work on my mother’s pc, when I’m logged on in my account. I couldn’t update Dragon or Chromodo on her pc. At launch I get an error msg that it’s crashed and do I want to relaunch. A continuous loop. Thought I’d found a way around it when they both updated and launched fine logged on as me. But switching to her acct caused the loop again. So, I have an old version of Chromodo on her pc, too.

I have the same extensions on her pc and my laptop and enabled npapi. But I don’t like using her pc for Netflix/Prime viewing.

Somewhere in this topic someone mentioned making a change in Netflix account settings and didn’t give any instructions on where to find the setting to make html 5 or Silverlight your viewing preference. I can’t find this setting anywhere in Netflix. It is available in Prime, but I can’t get Prime to work in either Comodo browser any version. It use to work. No clue why it’s not working. Get drm 347 error msg.

The latest update to chromodo ( Version ) has an incompability issue with both netflix and viaplay.

Netflix gives the specific error code: M7355-1203 “we have problems with playing netflix in your browser, makesure that you are using an official version of Chrome”.
Viaplay just hangs in an endless loop while trying to load the content.

Any update on this

Comodo is working on it according to Shane. That’s all I know and there is no ETA.

i have the same problem only with google store where i have 2 movies i cant watch at the moment because of the same problem.i am on dragon and chromodo since i refuse to go back to chrome when 3 non refreshing tabs in chrome eats up 7gb of my 8gb ram when i upgraded it ate 15gb of my 16gb ram when i upgraded again it ate 31gb of my 32gb ram and still its only 3 tabs that do not refresh. also i am having the problem that when i watch youtube videos that are just uploaded i cant watch 720p or 1080p untill 3 days later thats on chromodo on dragon and on chrome when are you going to fix this since it works fine on firefox and at the moment even microsoft edge is getting better than chromodo, dragon and chrome so when are you going to fix these standard easy to fix problems? and yes easy to fix since no other browser has these problems

Just a note that this still occurs with Chromodo (not Dragon) as of this date.

I realize this is an older topic but is the exact same issue and I did not want to clutter the Forum.
Please let me know if I should start a new Thread if that is more helpful and I would be happy to. I did not need any specific help, merely submitting the information.