Error: Unite setup wizard ended prematurely

I get the following error message when installing COMODO Unite on my Win 7 64 bit PC when I try to install COMODO Unite: "COMODO Unite Setup Wizard ended prematurely … because of an error. To install this program at a later time, run Setup Wizard again. See the attached screen shot.

Well, I have run the Wizard, but the same message always appears. Any suggestion on what’s happening here?


[attachment deleted by admin]

disable UAC, reboot. make sure av is not running. start it now.

Sorry, no joy. The UAC was already turned off. Disabling the AV made no difference - I still get the same useless message that I reported above.

Any other ideas?

try this one with command com ( not sure this will rowks with exe ) - put installer to one folder and run it from there.

msiexec /i installer name.exe /log install.log

if comodo is listed on add/remove programs, try this as well

Thanks for the suggestions, but the application still fails to install. I tried running both the “.exe” and the “.msi” versions of the program using msiexec. I used both the dos cmd window and the Windows “run” commands. In all cases, I received an “invalid package” error message. See the attached screen shot. I also tried running the install in Administrator mode, but the same message appeared.

There are no entries for COMODO in either the uninstall app or in the registry. I also downloaded a fresh copy from the COMODO web site, but I still get the same “ended prematurely” error message.

If I can’t get this to work, can you recommend another vendor for software VPN support?


[attachment deleted by admin]

hum. if you ask me, it looks like windows issue rather than comodo setup. 0fc you are using right *.bit version ( 32 or 64 ) otherwise you caould start installer.

what you can do it;s check event log - control panel → admins tools - event log and check for anything with c unitte.

any other vpn ? what do you need it for ? desktop sharing ? gaming ? exchange for lan=vpn ? hard to say without knowing what you want to do.


I checked all of the logs, and there were no entries for COMODO. So I think that I need to look elsewhere for my VPN solution.

What I need is the ability for remote users to connect to an Apache Tomcat web server that is attached to my LAN.

Any suggestions?


hamachi, teamview ( not it’s with vpn too ), remoobo,

last morre thing what you can try. create new account with admins privileges and try insttall cu again. if error comes uout, imo it’s windows issue and only re-instalation will works on it ;/