Error: The message contents may have been altered . . . Solved!

I’ve downloaded a personal certificate with FF, exported it as per instructions and imported it into Outlook 2016 (Office 365) and everything appeared to be set up exactly as per the instructions shown - except when I’ve tried to test it!

I’ve sent emails to a couple other of my email addresses on the same PC and all the POP accounts receive the emails with the above error shown in details with the red line and exclamation mark

The gmail account I use however works perfectly on receiving an email with the digital signature showing

What have I missed or what do I need to change on the settings for the POP accounts?

After a bit of trial and error, it appears to be solved by unchecking the box: [b][i]Send clear text signed messages when sending signed messages

[/i][/b]This is shown as checked in all the Comodo instructions for import and use, but certainly with Outlook 2016 and POP mailboxes, should be unchecked. I’ve tested it with all my accounts and gmail and all working well now

Hope this helps anyone

thank you for solution. This really works for me