Error - Site Unavailable.

I have been using Dragon for several years.
Recently, such an error began to appear, as in the photo.
Often. Especially when reading the forums.
What could be the reason?

What Dragon version are you using? If you have a version older than v68 please update to the latest.
Thank you !

Yes. You’re right.
Version 52.
I click on the button - automatic update. The browser downloads a file with a new browser. But he writes that he is damaged.

Unfortunately you will have to manually download the latest version, Dragon v69 from (32 bit) or (64bit) and do a manual upgrade. Versions older than v58 don’t have the video implementation and will not update anymore due to a certificate check implemented in the updater.

Alex P,
Comodo Browsers Team

That’s exactly what i did but still website are not responding and while my internet connection is working fine that’s how i downloaded the latest 70 something version please check and report so we can get a stable version soon.

Hi, I just made a test and the download works, the manual update from v52 to v70 works. After that there are no problems with websites. And yes there may be problems on V52 that cannot be solved other than downloading the new version and manually opening the new setup and update the browser to the latest version. Thank you for your feedback and please let me know if you managed to update the browser.

i did manage to update the browser to latest version and now suddenly it’s working and loading websites… i do not know what happened. thank you for your quick feedback

Nice to know the problem is solved and we are sorry for the inconveniences that you went through with the old version of the browser.
Have a great day !