"Error loading shell32.dll. Invalid access to memory location"

When I Right Click and then Select “Safely Remove Hardware” I get the following error.

“Error loading shell32.dll. Invalid access to memory location”

I have Version with Firewall set to “Train with Safety Mode” and Defense+ set to “Clean PC Mode” with Leak Protection. When I change the Firewall to Disable I no longer get the error message and everything is fine. There are no messages come up from the firewall apart from the error message. There are no events. There is something obviously being blocked. What do i need to do?
Thank you for any help or information.

Edited insert follow-up

Well after posting this a diagnostic message came up from Comodo Firewall Pro saying that it had found some errors in the configuration and would fix the problems and asked me to re-boot.

On Re-Boot the above problem no longer occurs. So it seems that the software can fix some such problems itself if you are patient. Well-Done. I was beginning to think I should go back to version 2.4 but I will keep this version and see if it settles down.


I wrote too soon. I just tried to run a Control Panel Item and they all give me the same error message and this time the Diagnostics says that i found no errors.
Thanks again for any help.

Hi thefly

Sorry no one has answered you before now.

It sounds to me like you may have a bad install or a conflict with another app. What OS are you using and what other security applications are you running?


Sounds like a Defence+ rule blocking something. If it was me, i would examine any C:\windows rules in D+ and if i could not find the right one I would delete and rebuild D+ rules.

You have probably already thought of that, but thats all I can think of at the moment.

Hi both JJasper and Qazee, Thanks for your replies,
I have Windows XP Sp2 and I also have Emsisoft a-squared Anti-Malware and Mcafee Viruscan 8.5i.

As to Defense+ being the problem it is in fact disabling the Firewall that fixes the issue.

Strangely I have three profiles all of whom even when set to Admin one doesn’t have this problem but the others two do have this problem.

Sorry for bumping, but I have this problem too, and as I didn’t see any solution to it, I decided to take it up again.
I would like to know where I can access these D+ rules, and how do I delete them, and how exactly is it built up again? Can you give me a little more detailed explanation?

Hi AndreasC,

Can you please start an new topic. Be sure to specify your OS, other installed security apps, etc & Make sure you are using the latest version of CFP 3.

I will close this out-dated thread.


This topic was previously locked but I am adding a solution found by “Shoman” to this problem see below

"I had same problem and I found an answer to it! Go to COMODO Defence+ and switch to Advanced tab. Then select Computer Security Policy. Select "Add". Click on "Select" and "Browse", to Windows/system32/shell32.dll. Set it as an/a "Windows System Application". After that my system worked normally again!"

I hope you find this info usefull