Error "cmdhtml.dll wasn't properly signed. Installation aborted."

Hello.

I’m getting this error when I try to install CIS 11.0.0.6606 and 11.0.0.6710 offline installers, I haven’t tried previous 11.x versions.

The only thing I find when I Google this error, is an identical post from two months ago, with no solution posted. The only difference is that I’m trying to install it on Windows 7 Ultimate x64.

So far I’ve tried installing v11 with CIS 10 already installed, with it uninstalled, with it removed using Comodo Uninstaller, and on a clean Windows installation (v10 still installs fine on it after v11 fails), and it’s always the same.

Is there any solution to this? Or, at least, an official way to download older offline installers without getting them from 3rd parties?

Also, since there’s only offline installers for CIS now, when I only need the Firewall the tray icon becomes useless since it turns into a red square after disabling the real time scan, is there any way to avoid that?

Thank you.

Update:

Offline installer works fine if it has access to the internet.

Online installers give the same error if there’s no connection or if blocked by the firewall.

Once cmdinstall has had access to the internet, the offline installer works fine even if the installation gets cancelled and then started again without a connection (all temp files deleted).

Is that on purpose, does the offline installer require an internet connection in order to work?

Is this with or without SP1 installed? I would install all Windows updates prior to installing CIS. As for online access, it only uses it to activate the license (free or paid version).

Hello futuretech.

I have tried with two different Windows 7 Ultimate x64 SP1 installations at different stages of updating, the SP1 is native, not slipstreamed.

Pretty much everything I’ve tried has been done using a disk image that’s one year old, it’s updated with the May 2016 rollup and updates up to July 2016 rollup (using DISM, no third parties applications). I’ve also tried installing CIS after installing updates up to the 2018-09 rollup, nothing changed. Also tried manually updating the root certificates, still no change. I kept using this image since nothing changes with other setups, even on other computers.

I’ve also tried with a fresh installation of Win 7 using an ISO which includes the rollups up to July 2016, because this image has some disabled services and other stuff removed, that one was a clean install with nothing touched, the result was still the same.

The logs I get are like the one from the other topic by user Tesseractus, they stop at the same point, saying cmdhtml.dll signer is ‘’. If I let cmdinstall connect to the internet, the log keeps going after that point, and it reports the actual signer on that file and some others.

Once I’ve tried this: start the installer, let cmdinstall go online, wait for the welcome screen (the one at the beginning of the installation), then unplug the network cable, and keep going with the installation. The result has been this: after it ended the removal of the installed CIS, at the point where it should give the dialog to restart in order to continue, the popup only flashed for an instant and closed itself, and even the installer got deleted (I mean cispremium_only_installer.exe, which was on the desktop), and everything ended there. I’ve never seen any installer actively deleting the original installer file on top of the temp ones.

The log there ended with messages about checking online for a license, and stating that it couldn’t continue because an internet connection was required (the offline installer used to work fine offline and then CIS required a connection after the whole thing was installed).

Another time it worked fine starting the same way, letting cmdinstall go online, waiting for the welcome screen, then closing it and restarting the installation while offline.

As I said in the other post, online installers give the same error when they are started offline, but once cmdinstall has had access to the internet once, starting online installers while offline gives the expected error of having no access to the internet.

In any case, logs say cmdinstall checks for the license and sends machine and installer IDs to Comodo servers before getting to the welcome screen at the beginning of the installation, once that is done the installation can be cancelled, started again while offline and it still works.

I have version 10.0.0.6092 installed on this image, the newest installer I have saved is still v10 and it still works fine when used offline.

I rarely download new installers, I usually do when there’s a new version and I stick with it with online upgrades/updates till the next one, so maybe I just missed an update where it’s been said that the offline installer is now one of those “offline” installers that still require an internet connection in order to start the installation, and not a proper offline installer anymore?

I just downloaded 10.2.0.6526 and 10.2.0.6514 offline installers and they don’t do that (haven’t tried older versions), 11.0.0.6606 is the first one to do so.

I had installed the CIS beta version of 11.0.0.6704 on an offline system that was installed using the standard Windows 7 sp1 install disc and has not had any other updates applied to it, and I didn’t have issues with installing CIS. Weird.

I am having this very issue too, with CIS 11.0.0.6710, offline installer.

Installing on a clean Windows 7 Ultimate 64bit .

I downloaded the Offline Setup from the “Released” thread here. I checked the provided hash.

Can’t install Comodo, need the machine badly. :embarassed:

I think the problem is that that DLL is signed with a cert or two that Win 7 Pro 64-bit (and other versions probably) doesn’t always trust. Windows updates and service packs probably add and remove this trust which would explain why only some computers have this problem.

To fix:

  • While that error is up find that cmdhtml.dll file. It’s probably with the rest of the install files in your private Temp directory. Alternately you can use something like 7-zip to extract the files from the installer exe.

  • Look at that file’s properties and look at the Digital Signatures tab. For the latest version as of today, there are 2 sigs. One with an SHA1 hash and one with an SHA256 one.

For each of those sigs I looked under Details until I found the View Certificate button, extracted it to a CER file, then found that file, double-clicked on it, and installed it to the Trusted Certificate store. I may have put one into the Personal store too. I never use “automaticly select” store though b/c I don’t know exactly what it does and it’s caused me problems with IIS servers before.

After reading this thread more thoroughly, I tried to install the offline installer, but now with internet connection. That did the trick, it installed without issues.

I wanted to prepare a virtual machine with disconnected networking. You know, it would be good idea to install a firewall first and then connect the machine to Internet.

Apparently the offline installer works only with Internet connection. Why is it called “offline” then?!