error cav 003-help needed

hi can somebody help me???
i install comodo antivirus but when i rebot the system give me this error
comodo antivirus encountered an error
number cav003
description on access scanner failed to start.

i try to start from the screen of antivirus but the answer is the same error.
can somebody help me on this

Sorry I can’t help but welcome to my nightmare.
This software won’t uninstall properly and a promissed fix for this error is about 4 days late in arriving.

Well… I have the same problem and nobody here care about that…


Currently Beta 2 of CAVS is scheduled for release on the 12th (this date may change) see if the beta 2 version of CAVS fixes the issue.

here’s a solution(100 percent depends on computer).

  1. Go to Task Manager(Ctrl+Alt+Del). Click on Processes and then find cavasm.exe. If the process cavasm.exe is not there at all, that might be a problem.

  2. On-access scanner won’t work in safe mode. Switch back to normal mode.

  3. Go to search. Click on all documents and files, then type cavasm.exe and press enter. If there are no results, be sure that it’s searching in hidden and system folders, and activate indexing whatever.
    Basically, if there are results, there should be two files that say cavasm.exe(file might not have extension-that’s okay). If there only one file that’s says cavasm.exe, that could be a problem.

Btw, the on-access scanner(cavasm.exe) can really freeze your computer. Ending the process will automatclly restore the computer.


When will we be able to download CAV that works…have C firewall and that is brilliant! But system freezes on download of CAV…please I really want this program!

Hunh. So I’m not “the only one”. Just downloaded and installed this yesterday, and the On Access Scanner will not work whatsoever. When I boot, or when I try to directly start it up, I get the famed CAV003. Misery loves company. I do not have cavasm.exe running, but I didn’t see anything that told us what to adjust if it was not there - should we or shouldn’t we attempt a direct start up of it, and will that if so solve the problem ongoing? Anyone yet find a definitive solution?

Also noted upon installation with every single non-necessary thing running that the email scanner complained about a failure, but upon restart it is reported to be functioning. Have to wonder if it is or is not.

I have to believe this program has significant potential, but how the heck did it get such glowing reviews when so many of us have run into this brick wall? Looking forward to a fix so I can actually experience it the way the author intended…

I have this exact same problem. I have reported it to Support - copy of e-mail is below. Do you have a 64-bit CPU like I do?!!?


I have installed CAV 1.1 today and cannot get the On Access Scanner to work
on my PC - I get a CAV003 error. It works perfectly well on my laptop (Intel
Core Duo processor).

Does this feature not work on 64-bit processors? It seems to suggest that in
your knowledge base. I REALLY would like to use CAV as my virus scanner so
I would appreciate any help. I did try installing the beta version but it
almost ground my PC to a halt so I had to uninstall it and go back to version


System Details below:

Product Information
Build Version:
DataBase Version:
AllowDB Version:
Program Updates Version:

License Information
License Status: Activated
Product Installation Date: 11-Nov-2006
Product Activation Date: 12-Nov-2006

Program Files Information

System Information
Operating System: Windows XP
Operating System Version: 05.01.2600
Service Pack: Service Pack 2
Internet Explorer Version: 06.00.2900

Hardware Information
Central Processing Unit (CPU): AMD Athlon™ 64 X2 Dual Core Processor
Total Memory: 2046MB

I also got the same problem (CAV003 - On Access Scanner failed to start). I am running Windows XP ro 64 bit version. Does anyone know of if a solution is available?


Now that you mention it, I got the same error after installing CAV 1.1 on my AMD Sempron 3200+ 32-bit machine running Windows XP SP2 Home Edition. After rebooting Windows however, not only did CAV give me the CAV003 error code complaining about it’s On Access Scanner not starting up properly, but it also completely locked up Windows by preventing Explorer from starting up properly. So I am unable to check to see if cavasm.exe is listed in Task Manager. By the way, does anyone know if the latest version of Comodo Firewall could be blocking it’s On Access Scanner (cavasm.exe) somehow?

Because of this, I’ve disabled the software in safe mode and reinstalled the avast! one (at least for now). I just hope that Comodo will have this problem fixed in the next version of their Anti-Virus software.

Unfortunately CAVS is not 64 bit capable yet. Comodo have been asked to modify their web site to more clearly delineate what versions of Windows CAVS is suitable for.

There will be a 64 bit version released, but exactly when is up to the code lab monkeys.

Sorry to be the bearer of bad news.

Ewen :slight_smile: