Error 5: Failed to launch~cfpconfig.exe; Access denied

Attempted to update CIS v3.9.76924.507 to v3.9.95473.509. While the updater was attempting to copy cfp.russian.chm file, the error message appeared: “Windows cannot access specified device, path, or file (C:\Program Files\Comodo\Firewall\cfpconfig.exe). You may not have the appropriate permission to access them.” Then the following message: “Comodo Firewall-Updater Error 5: Failed to lauch C:\Program Files\Comode\Firewall\cfpconfig.exe; Access denied.”

This happened twice, on different boots.

I was logged in as Administrator.

Strange to say, the Comodo knowledge base knows nothing about Comodo Firewall-Updater Error 5.

Any ideas?


OS: Xp Pro, SP3

From The Error Message You Have Provided, It’s Clear That Its A Permission Issue . You Can Check The File Permission For The Current User Under The Security Tab Of File Properties. Make Sure That The Current User Has Provided Full Control Access And If Not Provide It And Check. I Would Suggest You To Provide Full Control For The Entire Folder Itself. To be More Precise You Will Get This Message If You Don’t Have The “Read & Execute” Permission Is Not Provided.


Thanks for the reply.

I shoiuld have said that I am running XpPro, Sp3. On my system there is no Security tab for cfgconfig.exe Properties.


I Know Well That You Are Running XP Pro SP3 Since You’ve Mentioned On Your First Post Itself. You Might Have Installed Windows XP Professional On A System That Is in a Workgroup, So The Security Tab Is Hidden By Default. Security Tab Is Available Only To Administrator Or Users With Administrative Rights. So Make Sure You Login As One And Security Can Only Be Set In An NTFS Partition.

So To See/Unhide The Security Tab, Just Use the Following Steps:
Launch Windows Explorer Or My Computer.
Click On The Tools At The Menu Bar, Then Click On Folder Options.
Click On View Tab.
In the Advanced Settings Section At The Bottom Of The List, Uncheck And Unselect (Clear The Tick) On The “Use Simple File Sharing (Recommended)” Check Box.
Click OK.

If You’re Still Having Problem To Reveal Or Display The Security Tab On Files Or Folder Properties, Check Out The Following Registry And Set The Value To 0 Or Simply Delete The Key:

Key: Software\Microsoft\windows\CurrentVersion\Policies\Explorer
Name: Nosecuritytab
Value: 1

Thanks, Napsterz.

I followed your instructions and enabled the security tab for file profiles, and I gave all users full permission.

When I clicked Check For Updates, I got the message that Comodo is already up to date, and when I checked About Comodo it says that I do have v3.9.95473.509, which is the latest version and the version I was attempting to install when I got the “Failed To Install” message. So, either the error message was wrong, or the program is wrong in thinking that it is up to date. I’ll just ignore this question and see if the next version Comodo releases installs without error.

Thanks for sticking with me. I learned something.


I updated Comodo on several machines, and I ran into the same message on two of them. Apparently the problem is that I was not present for a timely response to a firewall message prompting me to give the updater permission to access the internet. I am also in the situation where Comodo now says it is up to date and I cannot rerun the updater. I assumed that the only thing not installed was some kind of Russian language support that I don’t need anyway.

I am a little mystified why Comodo needs to give itself permission for its own update.

This brings me to one of my favorite gripes. Why cannot the programmers who design update wizards bundle user input at the beginning? Even the nerdiest of use don’t really want to sit there for twenty minutes and watch everything!

renardym wrote:
“I am a little mystified why Comodo needs to give itself permission for its own update.”

Yes, especially when you have instructed it to treat the application as an updater and have switched to installation mode.


This solved the update problem for me.
Thank you

You Are Welcome… :slight_smile: