error 1603 on new install of comodo firewall

when i trie to install Comodo Firewall for the first time (no previous versions installed) i recieve the error
‘there is a problem with this windows installer package. а program required for this install to complete could not be run. contact your support personnel or package vendor’

and in the end i recieve error 1603. the installation was reversed.

Now i notice i still got the process cmdagent.exe running and there are possibly other remnants left.
(clicking on properties of cmdagent.exe under services gives: “The system cannot find the file specified”)

My question is if you can help me get the firewall installed properly (which i would prefer) or if you could help me remove the remnants of the installation.

p.s. I am running windows 7 ultimate and i don’t get the windows installer error when installing other programs.

Kindest regards

See if you can find a solution in Error 1603. Fatal error on installing V4.

I tried the Uninstaller Tool v0.3b and i think it removed the remnants. there is a register key HKEY_LOCAL_MACHINE\SYSTEM\Software\COMODO left should i delete that before trying a reinstall?

i tried to reinstall and got the same error as the person in the third post of; i tried the same method and now i have it installed but when i diagnose i get the same result as crash1.
which is:
Is there any way i can get that fixed (i have no other pc where i can install the firewall like crash1 to get the registry items with cavshell from) or is there another way to make the firewall run from this point?

Kindest Regards

Try unregistering the cavshell.dll.

Open the command prompt and type in and execute the following command: REGSVR32 /u C:\Program Files\COMODO\COMODO Internet Security\cavshell.dll .

I get the error: The module ‘cavshell.dll’ was loaded but the call to DllUnregisterServer failed with error code 0x80070005.

when i run as administrator i get the same message but with error 0x8002801c
which seems to mean that ‘the COM object is not registered or has already been unregistered’. if that’s true then cavshell.dll is not registerd and i searched the registry for the dll and indeed i got no hits.

so what to do next

Kindest regards

See if the solutions here by Languy bring any solace.

When CIS in uinstalled try the following. For problems with Windows installer you can use Windows Installer Clean Up utility. This tool cleans up all Windows installer related traces from your computer. It will allow you to run an (un)installer where it was getting blocked because it couldn’t find a needed file or says the products is already installed.

This tool does not uninstall a program.

As it is the firewall part of CIS seems to be working, when i use diagnostics the only failed entry is cavshell.dll.
I read somewhere it’s for the antivirus part of CIS so if i only need the firewall (i have another antivirus) can it be used this way without problems.

If there are expected problems with the firewall part with cavshell not working; i tried to use msicuu2.exe and it gives the error can’t load script C:\Users(username)\AppData\Local\Temp\IXP000.TMP\StartMsi.vbs (acces denied).

even running as administrator.

If there are expected problems with the firewall part with cavshell not working; i tried to use msicuu2.exe and it gives the error can't load script C:\Users\(username)\AppData\Local\Temp\IXP000.TMP\StartMsi.vbs (acces denied).

even running as administrator.

Did you run Windows Installer Cleanup utility after you uninstalled CIS?

yes i uninstalled CIS and ran the CIS cleanup utility and when i trie to use the windows installer cleanup utility it gives that error.

Before i uninstalled the firewall bit seemed fine (i don’t know if cavchell is needed for the firewall part or if it gives problems using the firewall)
but if i used the diagnostics tool it gave a failed value for the module cavshell.dll.

Kindest regards

May be left overs of previously installed security programs are in the way. Try using removal tools for those programs. Here is a list of removal tools for common av programs: ESET Knowledgebase .

Does that bring a difference?

i have macafee 8.7.0i running and SAS 5.0.1118 professional can those give problems for using the firewall part of CIS? windows defender is installed by default, i have it dissabled.
Windows firewall is also disabled.

I have never uninstalled a security program.

Can you see if temporarily disabling MacAfee and SAS makes a difference or not?

so i should reinstall CIS now with macafee and SAS disabled and see if the diagnostics still give the failed or should i disable macafee and SAS to trie and make windows installer cleanup utility work?

Please do both. First try to run Diagnostics with the two disabled. Then do a clean installation with the two disabled.

When doing the clean installation proceed as follows:

  • Uninstall CIS
  • After uninstalling or when the uninstaller did not run boot into Safe Mode
  • In Safe Mode run the clean up tool
  • Boot back in Windows
  • Run the Installer Cleanup Tool for Windows Installer and remove CIS traces when present
  • Start installing with the two on access scanners disabled

Let us know how things go.

i did a clean install of CIS with both SAS and macafee disbaled and it gave no prblems during install, i did diagnostics and it did not find any problems with and without macafee and SAS :slight_smile:

i didn’t need to run windows installer cleanup utility (which didn’t work anyway).

Thank you very much for your help!

Ok, I hate to sound like I am bring a dead post back, but I just want to say after reading this thread, I have had the same issue ONLY on my Win7 64bit PC and not my XP 32bit laptop … it seems to happen with every single release (minus one or two builds perhaps) since 4.x …

The method of rebooting during the install and then when Comodo comes up “with errors” … hitting diagnose and that fixes them (i think a re-re-boot may be needed here) would get things working again

THE POINT of why I am posting this is that despite the fact I hate Mcafee, I to have SAS and think it’s a great product. I had network issues and removed Comodo (temp fix to eliminate variables) and need to reinstall now. I am going to remove SAS completely …reboot then try the Comodo install

The Point is IF this works (without the method above, as I said) for a “normal” Firewall Install, we can pinpoint this issue doesn’t have (in some cases, i guess it would) to do with leftover Comodo items, but rather some conflict with SAS (which does load a driver or service, I believe)… in addition to searching any SAS forums they may have on THEIR SITE, I am hoping Comodo Support will take a look at this for future releases and maybe make some small modification to the installer to avoid this issue… .

WORST COMES TO WORST, I remove SAS … install new Comodos when released, then reinstall and reupdate SAS (which i know how to backup the def file for SAS anyway) … at least i can more (and others who read this with the same issue) preciously pinpoint the issue or at least what program (SAS) would be the cause of this. Again, I hate to “plug” a program, but other than Malwarebytes, SAS is one of the only other Malware scanners I recommend… This may be a conflict with the Comodo installer on some system, though SAS is a fully legit and good program. (sorry Comodo, if that is like advertising)