Error 1603. Fatal error on installing V4

I have deinstalled V3 to install V4 (Firewall only) on XP SP3. I have tried many times with no luck to get it to install. Any ideas on what causes this?

Try this clean up tool to get rid of v3 left overs.

To get rid of possible installer related information of v4 use Windows Installer CleanUp Utility and see if it mentions CIS v4. If that is the case simply delete those entries.

Keep us posted.

Google “Error 1603 msi installer”, i saw many possible problems, like:

  • Short file name creation is disabled on the target machine (regedit, navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem, make sure the value “NtfsDisable8dot3NameCreation” is equal to 0).
  • An Install Script custom action is prototyped incorrectly.
  • A file is locked and cannot be overwritten. (reboot & try again)
  • The Microsoft Windows Installer Service is not installed correctly (reinstall from
  • The Windows Temp folders are full (clear your rubbish bin).
  • The setup was corrupted after installation and, therefore, fails with this error during un-installation (download again, check file system for erros).
  • An older version of Install Shield Developer is being used (see above, get 4.5).
  • A general error occurred during the installation.
  • Print and File sharing is not installed or enabled when installing MSDE 2000.

Thanks EricJH. The cleanup batch file did the trick V4 installed OK and looking very good
Thanks again.

Hello, all:

Would someone kindly tell me:

  1. How to tell which version of Windows installer is installed.

  2. How to find the latest version which can be used with Windows 7 - Version 4.5 cannot!

Thank you.


Moderator Ronny did some investigation in the Error 1603 and found that removing the following registry key seems to do the trick to get rid of the error: HKLM\Software\Microsoft\Windows\CurrentVersion\Uninstall\Comodo Internet Security .

I am on Win 7 and assume the lastest version of Windows Installer is already in Win 7. The v4.5 redistributable dates back to 2008.

Hello all~

I am a completely new user to Comodo’s products and I am getting the same 1603 error as listed here (screens for those interested: & I have searched the forums a little bit and from what I can tell the solutions offered by members so far have been for users who have already used the Comodo Firewall (and other software) previously on their systems whereas I have not. I’m really new to understanding firewalls, installing them and understanding how they fully work so I am at a loss on how to fix this error. I am guessing this perhaps has to do with my Windows Installer? I am aware of this link that will take me to the Windows Installer 4.5 download page but which downloads do I need? All of them? Only some?

TIA for any ideas/suggestions.

The file you need to download depends on the version of Windows you are using. What Windows version are you using?

Windows 7.

There is no download for Win 7. I think the v4.5 installer is already integrated with Win7.

Did you try the clues posted by Arkangyal in the above?

Yippee!!! Thanks Eric. I ran the Cleanup Tool for Comodo, restarted, ran it again, restarted, and reinstall V4 successfully. Thanks for the help.

i tried the clean up and all the other solution and nothing works, after activation du noyau the installation stop, is there a way to donwload the v3 version to put it back

:-TU Thank you, EricJH, it worked for me too - using Danish Windows XP SP3 … :-*

I had the same install problem and solved it by doing a registry clean - something I find worth doing on a fairly regular basis.

I have no connection with the product, but I’ve always found Eusing Free Registry Cleaner to be safe and effective. You can get it at

I had the same problem. I had tried couple of times to install but each time it failed. Finally, after uninstalling Comodo Secure Email it worked. Just to let you guys know.

This is my first time posting… just wanted to let everyone know that the above information worked for me. I was getting the 1603 error when I tried to update to the new Comodo today.

As with the original poster, I too only wanted the Firewall and I am using XP SP3. After two failed attempts on my own, I found this thread and used the CIS Clean-Up Tool and I also ran a little program called CeanUp! just to clean out all the temp folders and junk. Also want to mention that I was careful to save the file to my desktop first and close all open windows, turned Windows Firewall OFF (had to have it on all day due to Comodo being gone), then crossed my fingers, closed my eyes and said a prayer! And it worked! Third times the charm, right? With the right tools that is.

Just wanted to say thanks for the Clean-Up Tool and to Mod EricJH, you saved me!

I also received 1603 installing V4. I have used Comodo versions for a couple of years and found the last install went ok but I kept getting error and failure for updating. I wiped my version from my PC, ran register cleaners and V4 came back with 1603 every time. I ran the “Clean up tool for Comodo”, installed V4 and presto, it loaded and updates fine. Much appreciated to everyone for the info to get this right…

Thanks heaps Eric. I ran the Cleanup Tool for Comodo, restarted, ran it again, restarted, and reinstall V4 successfully. Thanks for the help.

i have the same 1603 error ,i have installed WindowsXP-KB942288-v3-x86 ,Ran CIS Clean-up Tool ,remove invalid resgistry entries with winxp registry cleaner and junk file cleaner.window installer cleanup has no entries of comodo.
Still no luck,please help me guys or can i install the previous version.

Does the microsoft windows installer cleanup utility ask before deleting anything.? I have the 1603 error on upgrading to v 4. Back to v 3 while fix this