Error 104 on Update


I’ve tried the updater, several times now and always at 82% I get the error 108 notification.
I’ve switched off anti-virus, and switched the firewall off as well.
One by one I’ve rebooted with Application Monitor, Component Monitor, Network Monitor and Application Behavior Analysis turned off. Still get error 108 at 82%.

What am I doing wrong.?
Can I just go and download the new version without using the updater if I uninstall first ?


Hi and welcome,

You can download the new version from you will need to uninstall the old version.


Thanks Mike,

OK have done all that, thanks.
Install went OK, rebooted and all went fine for about a few moments.
After about 2 minutes of re-starting the computer I get a Pop-up from the task bar from CPF saying '

Can’t initialise session manager: Fast user switching not supported!

About 30 seconds after that the AVG e-mail scanner then complains it has been closed disabled ( I cannot re-start it ).

I’ve removed both CPF and Comodo Backup which I also had installed. Everything operates as normal.
Re-installing the latest Comodo Backup does not bring up any problems, but as soon as I install the latest release of CPF I get the same problems as above.

Have you any ideas ?
Can I go back to beta ver CPF_2.3.3.33_BETA until this is sorted as that ran quite happily ?

Cheers now

I saw in another post that “Terminal Service” had to be started and set on Automatic to prevent this. I had the same problem you are having but after setting Terminal service to auto it stopped.

I have the same problem except different error code.

If i use the “check for updates” in the comodo control panel or the auto updater build into CPF i get to 82% and get Error 108: Could not complete update process

Note: i also have AVG (free) installed.

Btw, Is there a way to download the program without entering my name and email again on the download page?


XP Pro SP2
Intel Core 2 Duo
2 Gigs RAM

I think it’s not AVG related… I use avast and have the same trouble.
Did you try fully uninstall, then boot, then install the new setup.exe file?

I follow this :wink:

Definitely not AVG related, because I get the same thing. Tried a complete fresh install and never even get to the activation part. :frowning:

You’ll need a new registration key. The codes are single use. So, as long as you remember the URL (check your history) you can download again without it, but you’ll need to register to avoid nag screens.

OOpps - My Bad - Should have been Error 108 on Update - Sorry about that :-[

However, thanks for all your help.
Terminal services now switched to Automatic - and all appears well ;D

There is one thing tho’, I had to re-boot three times after install to get all the settings saved correctly in the application monitor, (The correct settings would be there, but programs would still complain about non-connectivity.)

BUT, its working well now, and no problems - thanks again for all your help 8)


this is what ive ended up doing, uninstalling new version, restart, install new version then restart again. its worked doing it manually. one note though, after i installed the new version it started loading up windows (got past the windows loading screen) then went to a black screen. the floppy disk light stayed on and the hdd didnt do nething. i had to restart the machine and it worked second time round. this also happened to me when i installed a beta. anyone know why?

it turned out that after i entered the same name and email that i used before, it didnt even email me a new activation code. i just installed the new version and it recognised that i had a key already. im guessing the key is buried somewhere in the registry.


Just to let you know I think Comodo are working on changing CPF to give another update (by end of next week) so stop the message about fast user switching not being supported.

For the mean time, you can enable Terminal services, but either way CPF is still active and working fine.

You do not need to enter a new activation key as the certificate is installed on the C:/ drive in a folder named Trustix.



Why in the WORLD would Comodo depend on Terminal Services, which by definition allows remote logon to the computer?? That is disabled for good reason–it’s a security HOLE! Right?

It does not depend on it. Windows XP Fast User Switching uses that service. CPF just gives the notification. The problem here is CPF startup is slowing down which we fixed.

OK, fine. But Win2K Pro does not have Fast User Switching or Terminal Services, yet the same error occurs. I clicked to send in the “error report” when prompted (over and over); I just wonder if that can be verified as recieved.

We have fixed error 108 during update, had a problem on our update server side. It has been fixed on Sep 04, 2006 at 7:30 GMT.
Please try to take updates again.

Will do as soon as the 7 Sept updates come out. Unless it would really help you to have a test done before that?