Error 0x80072ee2 When trying to install Comodo Update

I have a Win7x64, SP1 machine running Comodo Firewall v. 5.3.181415.1237. While in my standard user profile earlier today I had an alert from Comodo that an update was available. After backing up, I logged into my administrator account, clicked Open on the icon in the notification area. Clicked on More > Check for updates. Comodo said there was an update available; I clicked on Start. The first time I tried this, I received an error message: cfp.exe Error 0x80072ee2. The second time, it only stated Error 0x80072ee2. Now it says The system cannot find the file specified.

I have tried googling on Error 0x80072ee2 and see there is one hit on your international forum/Italian language (which, alas, I do not speak).

Any suggestions on resolving this issue?

Updates are on pause because of a bug in 5.4.189068.135 Regarding ARP Cache Protection;;

Please See Here

Kind Regards

Revamping thread cause I’m getting the same issue using free version for my automatic update for virus database. Keeps saying to check connection. Are the updates being postpone on any more recent updates?