ERROR 0x80070005


I tried obtaining a Secure Email certificate from CSE. I got the mail to collect my certificate after I sent my details through CSE.

When I tried opening the link through received Email, I get the following Error msg.

“ERROR 0x80070005: CertEnroll::CX509Enrollment::p_InstallResponse: Access is denied. 0x80070005 (WIN32: 5)”

I tried it again even after getting my certificate revoked, both through CSE as well as Weblink but I still got the same response.

I am using the same PC to install the certificate.

My setup is Internet Explorer 8 ( also tried in compatibility mode) on Vista 32-bit. CSE ver
After IE failed I also tried in Firefox 3 without success.

I contacted the support team, who confirmed that they had successfully revoked my certificate and I shouldn’t see any errors.

Can anybody plz help ?

[attachment deleted by admin]

Can anybody plz help me with this ???

Hi, Nikmis

To resolve your issue we need some additional information about your software:

  1. What version of your OS? Do you have Service Pack installed?
  2. What version of IE 8 are you using? (IE 8 is still Beta and CSE didn’t report 100% support of it)
  3. What version of Firefox 3 do you have installed? And what proper error do you have in it?
  4. What rights does your OS account have? (Admin, Power User, User, etc)

Please note, that we recommend usage of CSE built-in feature - Certificate SignUp Wizard.
When you’re requesting certificate using it - you don’t need to do something on any web page:

  1. You start signup wizard and come through all pages.
  2. You receive e-mail AND CSE AUTOMATICALLY detects it and asks you to install certificate
    (this step would be done by CSE in case when your account is configured correctly (to test it - just try to receive e-mail via this account - You should see CSE popup))
  3. You can use your free certificate!

This means that You should successfully SignUp for certificate via CSE SignUp wizard.
If you get any error in it - please post it here.

I hope this post was helpful and your issue would be resolved soon.

Regards, Eugene


The problem seems to be resolved as I was able to install certificates on my system.

The problem was probably with IE 8. Instead of downgrading to IE 7, I used a Firefox add-on called
“IE tab” which emulates IE behaviour in FF.

I then tried to install the SE certif and did it successfully.

Anyway, just so if you would like to debug the issue I will give my setup details, in response to
your queries.

  1. I use Vista with SP1 installed.
  2. IE 8 beta 2.
  3. Firefox 3.0.1 with “IE tab” add-on.
  4. Admin rights.