Error: 0x80030201 in Comodo Free Firewall log

I was just prompted to update Comodo firewall on my Windows 7-PC and did so. Comodo Free Firewall now reports that version is loaded. When update is re-executed I get the following error in my log:

Error: 0x80030201 - The file download was aborted abnormally. The file is incomplete.
  1. Did I, in fact, update to the latest version?
    2.What is causing the error and how do I go about fixing it?
  2. Widows Solution center reported a problem with my system right after the firewall update, but neither indicated what it was nor found a solution, but everything, including Comodo free firewall seems to be working fine.
  3. Have I created a bigger problem or not?

Any light you can shed of this mystery would be much appreciated.

The update notice your received is not yet available to DL/install. This will change when the update has been made available to DL.

I had a problem with the updater of CIS earlier tonight. It would stop downloading at 10.3%. After 5 or 10 minutes and a few tries it would completely download and I could update CIS.

Did the problem fix its self or does it persist?

Thanks for the replies. Today my Vista Home Premium PC updated normally, but my Win7 machine still fails to update properly. Please see
the attachment. Is there anything I can do to fix the error?

[attachment deleted by admin]

Try emptying the c:\ProgramData\COMODO\Cis\wpTemp folder and see if that fixes the problem for you or not.

Thanks but that folder is already empty. I also checked for hidden files, none were found.

Hi pete.goss,
Try renaming the following folder to proto_v6old and then manually check for updates again.
C:\Program Files\COMODO\COMODO Internet Security\recognizers\proto_v6

If successful a new folder will be recreated and the old folder can be deleted.

Kind regards.

Hi Captain…

I renamed & deleted \proto_v6 as recommended; cold booted, a new folder was created; reinitialized Comodo Free Firewall update and received the exact same error as before. Sorry it didn’t work.

I thought about reinstalling the product from scratch, but because I have a download error of some kind, I’m not sure I won’t be left with less functionality than I have now, so I’ll forego a reinstall now.

Any other suggestions are always appreciated.


Hi pete.goss,
Sorry my suggestion didn’t help.

Kind regards.

Is the recogniser active? if so then it is working. But why it has a problem with reaching the download server that remains the question.

How would I check to see if it’s active? At first glance, it does not appear in task manager, but since I don’t know what I’m really looking for, I might have missed it.

Open up advanced settings and navigate to Viruscope and make sure it is enabled and a recognizer is listed and is also enabled. Viruscope, Display Pop up, internet Security, Sandbox Security Software | COMODO

In reply 3 you posted a screenshot of the update screen did you check view logs bottom right corner?

View logs only shows when there is a error or a program update, it usually gives a hint to the actual error problem.


  1. Viruscope is checked but no recognizer is shown as loaded. See attachment.

C:\Program Files\COMODO\COMODO Internet Security\recognizer.dll is, however, on my system (ver. How do we load it?

  1. Log Error code is shown in my first post:

Error: 0x80030201 - The file download was aborted abnormally. The file is incomplete.

[attachment deleted by admin]

Hi pete.goss,
You could try the following command, that failing I would suggest a re-install to see if that solves the issue.

  1. Open Command Prompt (As Admin).
  2. Copy/paste the following code and enter.
regsvr32 "%ProgramFiles%\COMODO\COMODO Internet Security\recognizers\proto_v6\recognizer_v8.2.0.4978.dll"

Kind regards.

Hi Captain,

I executed Regsvr32 recognizer.dll as the Administrator and was notified that it succeeded; however, upon running update within Comodo free firewall I received the same error as before. I rechecked viruscope within advanced settings and recognizer.dll is still not shown there. Things look exactly as my attachment in reply #13.

As to a reinstall, are any of my concerns expressed to you in reply #7 valid? If not, should I uninstall the firewall first or can I overwrite what I have?


Hi pete.goss,
You could try running the current installer over the top, it should show up as an upgrade (Screenshot).

The concerns that you posted in reply 7 could be valid, but if all else fails reinstalling might be a chance you have to take (Your choice).

Sorry I can’t think of any other way.

Kind regards.

[attachment deleted by admin]

Problem Solved!!! The overlay re-install worked. recognizer.dll is now shown in viruscope. Accordingly, Comodo Free Firewall now updates without errors.

Thanks for the wonderful support…issue closed, though I’ll let you know if I ever figure out what caused the problem in the first place.


Hi pete.goss
You are welcome.
Thanks for posting back.
It is good to hear that it is behaving now. :-TU

Kind regards.