Encypted drive will not mount

I encrypted my system drive(C) and my data drive(D) using Comodo Disk Encryption 1.2.65021.129. I decided to reset my system drive on the understanding that my encrypted data drive could be remounted on system restart. The C and D drives are on separate physical HDD.

Upon restart, I reinstalled CDE, Tools ----------> Add Encrypted Drive --------> Check Password -------> Selected the partition, entered the password, hash and encryption algorithm. Clicked finish, I am now told that the drive will be mounted but the system restarted(Is this normal?). After entering my password at system restart the system boots, but the drive is not mounted.

No I know I have entered the correct password because there is no ! mark. I have checked the drive partition and it is marked as RAW, which I believe is what it is supposed to be.

The problem is the drive won’t mount.

Does support actually exist within this forum? Or is it because it is a free product that support is non-existent… Can anyone help please. :-TU

I can try to help you. :wink: (but im not support)

Do you have any security software? .
Is your account a Admin or a Limited acount?

Thank You OmeletGuy for responding. :smiley: :-TU

I have Norton 360 v2, backed up by Avira Free edition, Spywareblaster 4.2 and the latest HOSTS file from MVPS.org (http://www.mvps.org/winhelp2002/hosts.zip). All security software is fully updated. My operating system (Windows XP SP3) is fully updated, including Java and DirectX and i’m running in administrator mode.

You could try to see if the driver will mount in Safe mode. (Im Hoping CDE can run in safemode)

OK, CDE does run in safe mode because the drivers for CDE are loaded when booting into safe mode.

Tried mounting in safe mode and this time i got a BSOD with the stop error:-

A problem has been detected and windows has been shut down to prevent damage to your computer.

If this is the first time you’ve seen this stop error screen, restart your computer. If this screen appears again, follow these steps:

Check to be sure you have adequate disk space. If a driver is identified in the stop message, disable the driver or check with manufacturer for driver updates. Try changing video adapters.

Check with your hardware vendor for any BIOS updates. Disable BIOS memory options such as caching or shadowing. If you need to use safe mode to remove or disable components, restart your computer, press F8 to select Advanced Startup options and then select safe mode.

Technical Information:
STOP 0X0000007E (0X80000003, 0X804E2A46, 0XF7B4AC50, 0XF7B4A94C).

Is this any help? ;D

Ok my best thoughts are to Disable all the security software (exept firewall, unless you have a router) you have then try to mount the harddrive.

Also… your not running Norton and Avast and Spywareblaster at the same time are you? You can only have one AV running at a time… orther wise it can cause problems.

Disabled all security software and tried to mount again but this time CDE won’t start at all. This time the system restarts after the CDE splash screen. My guess is that the program is actually trying to mount the drive and in the process, restarts. When CDE is run in safe mode I get the resulting BSOD, this time with this stop message:-

STOP: 0x0000007E(0x80000003, 0x804E2A46, 0xF729BCD0, 0xF729B9CC)

This now happens every time I start CDE and the program cannot be uninstalled either, saying that the drive needs to decrypted.

Any ideas?

The idea does come to mind of using a 3rd party software to decrypt the harddrive… it should work since you have the Key for it.

You could also see if windows would mount the disk for you.
http://support.microsoft.com/kb/307889/en-us (If you need any help with it just ask)

Lazy mod’s wont help. :frowning:

I sent a PM to someone to see if they can get support. :wink:

Tried mounting it within Windows, with no success. Windows just reports that the drive is not formatted.

I have tried a new strategy. Basically what I have done is stripped all no essential devices from my system and installed a clean operating system(Windows XP Home SP3) on a different drive with absolutely nothing on the OS, except, well the drivers Windows installed. I installed Comodo Disk Encryption, that’s it. No updates, no intenet, no security software, nothing. The same happens within normal mode, the system just freezes and within safe mode a BSOD (STOP: 0x0000007E(0x80000003, …) very similar to the one I posted previously comes up. The only thing that changes is the last three elements of the BSOD stop error. These are the three BSOD errors that I have got during different occasions:-

  STOP 0x0000007E (0x80000003, 0x804E2A46, 0xF7B4AC50, 0xF7B4A94C)
  STOP 0x0000007E (0x80000003, 0x804E2A46, 0xF729BCD0, 0xF729B9CC)
  STOP 0x0000007E (0x80000003, 0x804E2A36, 0xF7B4EC50, 0xF7B4E94C)

I have checked my error logs and their is a message , that comes up every time the system reboots

Event Type: Error
Event Source: Ftdisk
Event Category: None
Event ID: 49
Date: 01/10/2009
Time: 11:06:17
User: N/A
Configuring the Page file for crash dump failed. Make sure there is a page file on the boot partition and that is large enough to contain all physical memory. For more information, see Help and Support Center at Microsoft Support.

0000: 00 00 00 00 01 00 56 00 …V.
0008: 00 00 00 00 31 00 04 c0 …1…À
0010: 03 00 00 00 00 00 00 00 …
0018: 00 00 00 00 00 00 00 00 …
0020: 00 00 00 00 00 00 00 00 …

Clicked on the above link, which takes me to the Help centre, where surprise, surpirise, no information is available for this error (typical Microsoft, their OS, their errors, no information available). Some links are given though,

http://support.microsoft.com/kb/927749/en-us	*

Now the only one of these links that seems relevant is marked with an asterisk, any ideas? :-La :-TU

P.S. I’m also speaking to a support technician named Mark, via their ticket system, but I haven’t heard from him in 2 days… ???

I encrypted my system drive(C) and my data drive(D) using Comodo Disk Encryption 1.2.65021.129. I decided to reset my system drive on the understanding that my encrypted data drive could be remounted on system restart. The C and D drives are on separate physical HDD.


Have you restarted the computer during encryption process?

Hi Ionut, ;D :-TU

No, the encryption process was fully complete and everything was working well :-TU, that was until I reinstalled the Operating System :-TD. Now I have tried mounting this drive using a third party tool and exactly the same happens, same Stop messages etc. One thing I have noticed though is that within this third party program the data drive(K) in this instance is marked as bootable. Please see attached screenshot. Any thoughts would be appreciated, Nik.

[attachment deleted by admin]

I don’t use full encryption (anymore) on system disk without backup since it is just vain and dangerous… ( look at http://web17.webbpro.de/index.php?page=stoned-bootkit by example )

Disabling is perhaps not enough my 2 cents : Try a full uninstall & clean-up for crapwares like Norton…

Depending on your PC’s configuration i fear your system re-install made changes or bad marks on your disk or something like new checksums for recognised system components … sometimes ‘‘free space’’ look more suspicious than ‘‘unrecognised’’. At next step go carefully any wrong step can compromise your datas more …

By the : Ubuntu on a NTSF partition is just a bad idea ( if my guess from your picture is correct)… Try ext3 or ext4 : be carefull with NTSF write access it is still faulty sometimes you need a chkdsk from windows ask M$ why they made it so … Dual Boot from linux anyway you won’t loose your MBR …

Tracking your last message and M$ it looks like windows had an serious Ftdisk data flush error.

I can’t help you no more but i suggest you check TestDisk (Partition Recovery and File Undelete) good tool and tons of valuable informations ( like FDISK writes all F6 hexadecimal bytes into the 1st and 7th sectors of each track it intends to use for FAT tables. If you have accidentally deleted a volume, do not run any Microsoft FDISK program on it! )

TestDisk can be used to collect detailed information about a faulty drive which can then be sent to a technician for further analysis.

I saw that users of TC also reported full USB drive became unreadable with FTdisk ■■■■… Backup always & Good luck ever :wink:

Update 10/10/2009 : The mentionned stoned-pdf exploit is now detected by COMODO under PDF/Pidief ( a family of trojans that usually arrive in a malicious crafted PDF file that exploits the CVE-2007-5659 and CVE2008-0655 vulnerabilities. Successfully exploited PDF files allow an attacker to remotely execute arbitrary code. )


You haven’t told me that you have a multiboot machine :).
Which OS have you reinstalled?
OS Reinstalling means bootloader reinstalling.
I need the entire scenario in order to help you to get your data back.

  1. the initial configuration (number of disks, the partitions, the OSes)
  2. which partition have you encrypted?
  3. which OS have you reinstalled?
  4. which is current problem?

We are going to release a new version with some defects fixed as soon as possible. Please provide me theese details.


Old Configuration

Partition 1: Ubuntu
Partition 2: Windows XP SP3 (system partition encrypted with CDE)
Partition 3: Data drive
Partition 4: Data drive

Partition 1: Data drive(data partition encrypted with CDE)

Partition 1: Data drive

The OS I have reinstalled is Windows SP3 on HDD1, partition 2 with the same operating system.

The problem is once the operating system had been reinstalled HDD2 refused to mount within CDE, instead of mounting the system BSOD’s. The BSOD errors have been posted earlier, thanks.

Hello, is anybody out there. Comodo staff? ;D :-TU