Enabling War3.exe to use port 6114 [RESOLVED]

I just installed COMODO firewall and COMODO antivirus

I am trying to configure war3.exe to use port 6114 TCP/IP inbound and outbound. All my attempts to find where I would configure this have failed. Where would I be able to open ports and what would I type?

I see connection attempts in the Active Connections window, but no information is ever sent back.

There have been a lot of pop-ups and requests and its beginning to get tiresome. I was also wondering if there is a way to disabled some of these.

Thanks for your help.

[Topic Closed: If issue returns PM an online mod to open]

Go Firewall->Advanced->Network Security Policy->Global Rules->Add:

Action - Allow
Protocol - TCP or UDP
Direction - In

Source Address - Any
Destination Adress - Any
Source Port - Any
Destination Port - 6114 ->Apply

Move this rule to the top of the list->Apply

This rule will allow all incoming TCP/UDP requests to your port 6114. Make sure you really need this. It would be better to find out which servers are used by war3.exe and grant access only for them.

Hi Ammorth

Welcome to the Comodo forums

If you don’t want to make a global rule:

Every application that you have approved to access the internet will have an entry in Firewall ->Advanced ->Network Security Policy ->Application Rules. Click on the listing for War3 and you can edit it and define it as outgoing only, web browser, or trusted application and then edit that setting to allow for your port. You have pretty much all the flexibility you need to tweak the settings to how you want them.

If you don’t have an entry for your app in Application Rules click on add and make your own entry with custom rules.

Also use Defense+ under training mode when playing a game and it will eliminate the popups for you.

Hope this helps


Thank you both for the speedy reply.

Although both methods would seem to solve the problem, neither actually do.

Here is a screenshot of my active connections to show that people are reaching my computer, but nothing else.


(in case linking doesn’t work: http://pixloads.com/public/pview/46710/Active%20Connections.jpg )

Currently war3.exe has these settings:

Port 6114
Action: Allow
Protocol: TCP or UPD
Direction: In/Out
Description: Port 6114
Source Address: Any
Destination Address: Any
Source Port: Any (or 6112 - 6119)*
Destination Port: 6114

*I have tried both

Try this, please:

I got it, and I am kicking myself about it.

Windows firewall was on… (I turned it on while switching to COMODO, in-case something funky happened.

Its set to a trusted application and it works like a charm.

Thank you all!

Ps. Comodo Rocks, Windows… not so much.

Sorry, one correction. If you dont’ have Block all IP… or Block all TCP/UDP… entry in Global Rules, you don’t need any special Allow… entry for war3.exe in this section.