Enabling Internet Time lookup

For some reason I can not connect to time.nist.gov or time.windows.com to automatically synchronize the time. There are no rules blocking specific IP addresses and I tried adding time.nist.gov to the network rules but that didn’t help. If I turn off the firewall the connection works correctly, but obviously that is not the answer.
I tried removing all blocked applications and running the synchronize and answered yes to all the program to access the internet but that didn’t work either.
What do I need to change to allow this to work again?

You should find all the information you need in this thread:

Basically you need to allow svchost.exe an outgoing udp connection to time server.
And also to allow svchost.exe incoming udp port 123.
And no need to make any network rules.

Hope this helps.

I looked at the thread and at my settings. Svchost.exe was already set to allow TCP/IP and UDP traffic to all ports in both directions. The log shows that it is blocking the traffic as being suspicious so there must be something else triggering the firewall to block the traffic.