Emule Low ID and Firewalled KAD

Hi, I need some help with configuring CIS to run with Emule v0.50a. I had Commodo Firewall workign properly and was able to run Emule with a High ID and Open KAD connection, but since upgrading to CIS I cannot achieve the same results.

I have set up CIS using this guide http://www.techsupportalert.com/content/how-install-comodo-firewall.htm

followed by Enable File Sharing Applications like BitTorrent and Emule, Comodo Firewall

What am I missing?

Can you show a screenshot of your Global Rules and of the application rule you made for eMule?

Sorry if I have not open a new topic but the question is the same. This is not my first experience and, normally the use of eMule do not need particular prescription is sufficient to assign the standard rules for safe application. With my last installation Win 7 Pro fully updated and the last version of CIS I’m not able to have eMule working. At the moment I have not try the solution with 6 different rules but is it really necessary?

Thanks in advance

Could you show screenshots of your Global Rules and of the application rule you made for eMule?

The attachments jpg are referred to my working situation in several PC.
The same don’t work in the above explained installation.
A.s.a.p. I will try with the six different rules and I will inform you regarding the result.
If you need more information please do not hesitate.

Many thanks

[attachment deleted by admin]

You need to make rule in Global Rules in to open a port for incoming traffic. For emule you need to have two ports open one with TCP and one with UDP protocol. Keep that in mind when reading the following.

Read the following tutorial I made. Substitute the port numbers and protocol for your situation.

To open the port TCP 1723 for example

First step is to determine the MAC or Physical address of you network connector. Go to Start → Run → cmd → enter → a black box will show up and enter the following → ipconfig /all (notice the space before /all) → enter → now look up the Physical address and write it down.

Notice that Physical address = MAC address

Advanced Settings → Firewall → Global Rules → Right click → Add → fill in the following:
Action: Allow
Protocol: TCP
Direction: In
Description: Incoming Port

Source address: Any
Destination Address: Choose MAC address and fill in the found MAC/Physical address
Source Port: Any
Destination Port: 1723

Now OK your way back.

Thanks EricJH, the problem was solved but was also necessary to create a similar rule for UDP port.

but I do not understand why in certain circumstances it works without any added rules.