emule and bittorrent

(first a quick question…when launching some programs i.e. Mozilla firefox, comodo says firefox is trying to act like a server??? What does this mean and do I allow it?)

Ok that out the way, I want to ask about emule. This was running fine on my system but now with comodo I have a low id and cannot connect to the kad network. Even though in comodo it says emule.exe/destination:any/Protocol: TCP/UDP out/Permission: allow.

So from this I would pressume it to be working. No, the port test doesn’t work.

So please can someone help me to get emule running properly again with kad network and high server id.(kad says firewalled all the time).

Also bittorrent is the same, this is permanently firewalled now it seems—although the other day it was working fine.

Thank you for any help given.

hey do u run utorrent? whenever i run it, and try to access my webpages after, the web pages take longer to open! it’s annoying!!! (:AGY)

jalba, I’ve already answered your question. Please see here:

rabbitsfeat, your question can be answered in the ** FAQs/Threads - Read Me First ** thread:

[b]Constantly Same Alerts / Doesn't Remember Rules[/b] https://forums.comodo.com/index.php/topic,6908.0.html

The above thread references the server alert thingy. I’d personally leave the default Do not show alerts for apps certified by Comodo option. However, that is entirely a different topic, so let’s not dwell into that here.

[b]Emule, BitComet, BitTorrent, BearShare Lite, Azureus, uTorrent[/b] https://forums.comodo.com/index.php/topic,29.0.html https://forums.comodo.com/index.php/topic,411.0.html https://forums.comodo.com/index.php/topic,1022.0.html https://forums.comodo.com/index.php/topic,2562.0.html https://forums.comodo.com/index.php/topic,8049.0.html

Nope! None of these solutions work… tried the lot and still low id and no kad network… nor are these tutorials for setting up easy to follow.

Simply doesn’t work so changing firewall.

NONE worked? If you set the Allow All and it works, then it’s simply a matter of adjusting your Applications and Network rules. You can also upload a copy of your log file.

Thread: Important - Please read before posting:

Firewall Logs: 1. Open CFP to full screen 2. Select Activity/Logs 3. With the mouse, right click anywhere in the main window 4. From the context menu select 'Clear all Logs' 5. Restart CFP or Reboot 5. If necessary run the problem application 6. In CFP Select Activity/Logs 7. Right Click in the Log window 8. Select 'Export to HTML' 9. Save the file with a sensible name 10. Open the file in a HTML/text editor 11. Modify your external IP Address if shown in the logs (See Note) 12. Save the file as HTML (don't change the format to plain text) 13. zip/rar the file and post on the forum

Note: When posting log details on the forum, it’s possible they may contain references you your external IP Address. (The IP Address shown in the bottom right of your forum post) In consideration of the privacy issues related to this, we ask you to modify any reference to your external IP Address in the log, using the following example:

Your Address: 123.245.789.123
Modified Address: x.x.x.123

Some things to consider:
Network Monitor rules are hierarchical, that is, they work from the top down. Therefore, a BLOCK rule placed above an ALLOW rule will take precedence.

If you’re having problems with a specific application, check Application Monitor for a rule that BLOCK’s that application.

Here’s a zip showing hopefully where the problem lies…

thanks for any help

[attachment deleted by admin]

I have some ideas, but not certain if they’ll help resolve your issue:
I see some “C:\WINDOWS\explorer.exe has tried to use C:\WINDOWS\system32\svchost.exe through OLE Automation, which can be used to hijack other applications.” entries. svchost.exe is a legit Windows file and should be granted access on those OLE Automation. If there are any blocked Application Monitor rules on svchost, then delete them and restart eMule. If you have a router or networked with other computers, then you need to define a trust network in Security > Tasks > Wizards.

Ok thanks. I did define a trusted network and was working ok, but seems to have stopped working again now.

This is a problem I’m finding… things work for a bit and then don’t?

Very puzzling… will try what you suggested and thanks.

Oh what does OLE stand for?

I think this is the correct definition of it:

http://searchwinit.techtarget.com/sDefinition/0,,sid1_gci214126,00.html → Shorter description.

I can link you all the FAQ’s, but to keep it short you should only deny these OLE alerts if either of the 2 programs are suspicious (i.e. you don’t recognize them).

I’m really getting lost with all of this… how do I know if something is an OLE alert or not… can’t see anything about it anywhere.

emule is connecting to server but with low id… kad will not connect though.

I think I’ll just try a different firewall… save all this hassle!

I just wanna be able to allow or not allow a program… why can’t it be that simple?

Had enough of it tonight anyway… I’m off to bed. Thanks for all your help though.

Umm… if you receive an alert that contains the words “OLE Automation” then it’s an OLE alert.

I’m not the right person to help with Emule as I use uTorrent. There are many others who are more knowledgable to help you out if you ever return.

I’m not sure about emule, I still need to test myself but maybe what you are missing is to add a rule before rule #0 (Click on Rule #0, then right-click on Rule #0 > Add Rule > Add Before).

Comodo deserves “give it a try”, it rocks, a bit difficult to config some progs but with some patience and forum help you’ll get the right solution. :Beer

This tutorial es right but yeah, is needed to add the rules before rule #0


Now emule is working correctly :■■■■