Driver is not active... Bug?

Greetings all,

{CMF; XP Pro}

This latest version was installed via update from .12 since the Update became available (Thursday, as I remember).

I browsed through settings… then opened Main GUI window couple of times
Status bar reported “green tick” - Application is active and running.
I left it alone… it is running - fine then
My last session with PC was around 48 hours without switching it off.
Then just out of curiosity I opened CMF… and found:
Driver is not active. Please reinstall the product

Before proceeding I decided to restart PC.
And now it is active and running again… Hmm :THNK
So, for how long the driver wasn’t active?
Why such event wouldn’t fire up some kind of notification pop-up?

Forgive me please, for bringing CFP in to this section…
The same may actually apply to CFP.
There is Diagnostics, which may be initiated by user. Sometimes it will report a problem, which can be fixed. That is fine.
Again the similar Q: How long CFP may “work” having “a problem”?

Wouldn’t it be nice to have an option for both products to set a scheduled diagnostics?

If fixed by “internal forces” - they may remain silent, if not- let us know, please.

Thanks in advance
My kind regards

Hi Guys,

I made the same accidental discovery again
This time I didn’t Reboot but just exited and restarted the Application.

I am not sure that reinstallation will fix it unless you say so… (and promise (:WIN) )

My regards

If reinstall needed what do you recommend - just install over existing one or uninstall first?
What about some additional/special clean-UPs ?


Hi Folks,

reinstall will not work.

I have the same problem
I have reinstalled the program, but the problem is still there (XP SP2).

The only way I found to handle it is to shut down CMF
and restart it manually.
But I have to do this after every reboot because it happens
every time I boot the PC.

Nevertheless I would like to say thank you to the guys from Comodo
for their work with all the programs for free.

metamagic :■■■■

I’m digin’ this problem mates, this’ll be fixed (though still can’t reproduce this issue)

I initially had the same issue on my 2 XP SP2 Home machines. The driver itself seemed to be loaded properly, so I suspected it just wasn’t communicating with the UI. Having seen this before with a HIPS I used for a short time I decided, fully aware of the risk, to change the driver startup type to System. Since I did that I’ve not seen this or any other problem at all on either machine and that’s been several days now.

Hi Guys,

Thanks for all replies.

I’m not saing that I suspected as much - I was sure about that.

Mate! :slight_smile: Thanks. "Digging is believing! (:WIN)… Mate!

At the same time I do believe that there are difficulties in reproducing though, because it is kinda really spontaneous event here. It never happens as in metamagic case, when

I wish it was like that - for reproducin’-<digin’>-catchin’-Fixin’ purposes.

I have no doubts we’ll be fine soon with this (rather without), because it is (B)

My regards

Hi guys,

on my system, driver is reported to be inactive (red) on every reboot.

Exiting and restarting of CMF fixes the problem for the whole session (i.e. it stays green as long as the computer is on).

With the next re-boot it reports inactive again.

Vista Business 32bits
BoClean 4.25
Spyware Doctor

Harry (:NRD)

You should try cleaning the prefetch files. Worked for me. I used Vista Smoker. :THNK

Thanks for the suggestion did not work I think you have SP1 might be why.
Tried running it as adminstrator windows did not like that and stopped it running on startup in admin account it must have done something because if I now stop it after startup (driver not working) and restart CMF everything is working. ;D
Thanks Dennis

Hi Guys,

Back to the problem.
Due to known bug I was thinking to remove CMF from Startups.
Anyway after reboot (not every reboot though) you need to check it out; shut it down; and restart.
So, I was thinking to fire it up manually until problem solved.
But then… because it happens not every reboot as pointed and it always works the whole session fine when manually restarted, I decided to try just delaying CMF’s startup.
I used Startup Delay by r2 Studios
To be sure that all other (or most of) “starters” finished their work I set delay for CMF as 37 sec. (sure this value is very individual and depends on every particular startup you have)
Well… I gave it couple of days and I was making several restarts deliberately during each session.
Everything is fine. I never seen famous red status bar message since. The driver is always active! :slight_smile:
Needless to say - that was not a strict experiment and/or test because I did not have a chance to run all possible startup variants/combinations to find out when the conflict occurs. Definitely, the said program is not a proper Tool for doing that, but maybe the fact itself could bring some thoughts and developers will look at the problem from different angle.

My best wishes to everybody. :■■■■

SP1 in Vista cured it for me.
I think it was a lack of memory 1Gb on Vista which caused this problem.

Hi Dennis,
Is there any sources to read, which could confirm that Vista’s SP1 addressed the startups, so it cured this one as you said … and the 1GB “lack of memory” :slight_smile: in conjunction with this particular issue?
I’m not going to have Vista ever. but there are some people who may be interested.
My regards

Sorry no not that I know of only by experience every time I booted Vista I would have driver is not active only if waited 2 mins before I login or after login shutdown CMF and restart would it work. If I looked in Task Manager/Performance during the first 2 mins I had no free Ram using approx 850 (Peak 16secs.) the rest was cache none free.

After SP1 I did not have any problems 2 weeks now and CMF has always loaded I presume they have changed the way Vista starts it proccess, also the peak rise now to approx 770 and there is always some free Ram.

Hi Dennis,
Thanks for reply. Well. Our personal experiences matter a lot in this industry.
No doubts about it.
The XP startups are known issue and area of many conflicts.
It is very badly “manageable NOT” :-TD
Sure things don’t change by themselves. So if “after SP1” works better without any amendments done in troubled area - it should be something, which SP1 brought.
Some deeper diggings and readings needed.
I was thinking… probably Vista SP1 “improved” startup timing … and it takes 6.666 min now… so CMF starts after 2-3 min passed (:LGH)… just kidding.
As a matter of fact, are you using BOClean? It seems to me that it is heavier on startup than I would expect.

No I not using BOClean yet will try after update.
I have to admit there seems to be 10/20 secs longer before the login screen appears after SP1.
Computer Specs below.

Acer Aspire E700
Vista Home P. Version 6 Build 6000 SP1
Intel Core Duo 6300 [ at ] 1.86ghz
1024 DDR 2 Ram
Windows Defender

I’m having the same problem as well. I don’t know whats going on and I reinstall my vista cause SP1 slowed me down and so far what I’ve SP1 is not recommended for home users.

Sony Vaio CR36

Vista Home Premium
Core 2 Duo T8100 - 2.10ghz
2gb RAM
Comodo BOCleaner 4.5
Nod32 3.0
Spyware Doctor
Wndows Defender

Thats my laptop and I was wondering if the whole SP1 is not good for home true?

SP1 cured this problem for me.
Did you install SP1 from Windows Update.

Hi Guys,

CMF is still working flawlessly since I delayed it as I reported earlier.

Please don’t get me wrong because I am just making a remark which definitely will not help you. But I have to say: it is not “SP1 is not recommended…” it is Vista itself should not be recommended to any user. My opinion. When XP expired I am on Mac or Unix. Ubuntu already running on old PC. Testing… and I am Very impressed.

I know vista has some problems since It’s release but I got my laptop with vista on it and my only retail copy of XP is assigned to my old dell desktop pc. I’m just your normal pc user who surfs the web, play online games and other typical stuff. I’m not really that OS savvy or whatever… I’m here to learn and try figure things out and no offense taken.

I did has SP1 but it slowed my laptop down and I’ve read that SP1 just hinders the performance for home users. Don’t know if it’s true but I didn’t experience it.

No problems for me if anything it improved performance as I only have 1GB ram and this is a bit low for Vista I did SP1 from the download file not through Windows Update also uninstalled firewall and antivirus so I wanted to do it offline. I had heard that there could be problems using Windows Update.