Dragon: Youtube comment box error???

Posting this here so I don’t annoy anyone if it’s a simple fix.

I just downloaded Comodo for Windows 8, 64bit, last night and just started using the Dragon browser. The add-ons/extensions I have are only: PrivDog, Ever Note Web Clipper, and whatever else came with the browser. I haven’t installed anything else.

I imported all of my bookmarks from Firefox (just the bookmarks, nothing else) and as far as I know, have the latest version of the Dragon browser, being that I downloaded and installed it less than 24 hours ago.

The problem: I just went to YouTube to view a video for the first time since installing Dragon and when I tried to click the comments text box to type a new comment, a new browser window popped up briefly, loaded for a few seconds and then closed again. It’s like the browser is treating the text in-put box as a link instead of a text box. After trying to click the text box and after the pop up has disappeared, the text box gets a nice, yellow outline too. There is a similar yellow outline on this textbox as I type this but obviously, I am able to type this. Not sure where the difference is, other than I know that Youtube uses Java scripts. Not sure about this site.

I can’t really say how to reproduce this other than go to Youtube while on Dragon and try to post a new comment on a video. Either you have the problem or you don’t.

Nothing I’ve tried has solved the error and as I am totally unfamiliar with Dragon right now, I don’t have the faintest idea what the problem could be. I’ve never had this happen with any other browser in nearly 18 years of using the internet. All other input boxes seem to work. I can type emails in Google’s Gmail and post on the Nexus mods forum with no issues. Just seems to be specific to Youtube.

If anyone has had this problem and/or knows how to fix it, please let me know!? Or move this to the Bug Report thread if needed.

[attachment deleted by admin]

Hi and welcome nomaroos,
I can’t try this myself (Just thinking) as I do not have an G+account.
Please try disabling ‘Do not allow websites to know where you came from (suppress HTTP Referrer header)’, found under privacy in the advanced settings.

Kind regards.