Dragon Version 69.0.3497.81 can not connect to Google for real-time sync

I have just updated to the latest version of Comodo Dragon but the problem still exists. I don’t know why this still exists.

Hi dzu181,

Can you give us some more information?

What OS are you using?

Can you give us some steps to reproduce the issue you are seeing?


I am using Windows 10.
I opened the Settings of Dragon at chrome://settings/ , and then try to click “Sign in with Comodo Dragon”. Then I entered my email and password. Then it says some problems happened, and asks me to try again everytime.

Did you install Dragon from a clean install or did you upgrade from a previous version?

I installed the version 65, and upgraded it to the newest (32 bit version).
And also, I tried repair the browser into the newest 64 bit version, too, but the issue was not fixed.

Hi dzu181,
Can you provide some information regarding what Anti virus and firewall you have installed on the system, and if you have the Comodo DNS installed on the entire system or only in the browser or not at all. Or if you have any security extension that you might have installed in the browser.

Thank you !

I am using Comodo free Antivirus combined with Comodo Free Firewall. Also using Comodo DNS. In the browser I use Adblock Plus to block ads.

Hi dzu181!

You can try to disable Comodo Secure DNS and can you let me know if you deactivate Comodo Secure DNS does your synchronization work well?

[i]Thank you very much,


I have disabled Comodo DNS on both Dragon browser and the entire system, as well as the router, but the problem is not fixed. ???

Can you give it a try now? We made some changes to the sync service in Dragon and we need to know if it solves your issues.

[i]Thank you very much,


The problem still exists. :cry:

Also when testing DNS settings it is mandatory to flush DNS cache and restart the browser. Restarting the browser is needed to clear the browser’s DNS cache.

I flushed my cache and also I uninstalled the browser and reinstalled it. I am now using Norton Secure DNS, which are: and But, still, the problem exists. I can not sign in to any Google service.
I tried Touch VPN extension: Touch VPN - Secure and unlimited VPN proxy - Chrome Web Store, but it is still stuck.

Did you remove the Dragon profile in the AppData folder when you reinstalled it?

If you didn’t could you make a USB installation of Dragon in another folder? That way we know if the problem is related to your profile or with Dragon.

I tried installing portable version but the problem keeps on existing.
I also tried to download a chromium version that is equal to Dragon v69 from https://github.com/henrypp/chromium/releases/tag/v69.0.3497.81-r576753-win64 and download and install chromium-sync.exe. I saw that Chromium DID ITS JOB, there were no error with Chromium. However, Comodo Dragon is not that easy.
I have included the log file of my Comodo Dragon within this reply.
Hope you guys figure out what the problem was.
Thank you very much!

Thank you for testing. :slight_smile:

:a0 ;D
It finally worked!!! Oh my God I am so happy right now.
I am gonna switch from Chrome to Dragon from now.
Thank you so much for your help!