Dragon tries to install after update after specifically saying NO during install

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?: Yes 100%
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    1:? CIS version 7.0.317799.4142
    2:? Windows 7 Home Premium SP1 64
    3:? New install on laptop of windows. New install of CIS, without geek buddy,dragon or privdog, only AV and FW. The install had issues and tried to fix on the forum, read my thread here https://forums.comodo.com/install-setup-configuration-help-cis/comodo-dragon-installer-popup-how-to-remove-t103894.0.html
  • If not obvious, what U expected to happen:
    ? The final result is the dragon installer downloads with the new signature updates and tries to install
  • If a software compatibility problem have U tried the conflict FAQ?:
    ? There is no conflict
  • Any software except CIS/OS involved? If so - name, & exact version:
    ? No only Dragon
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    ? It is an installer update fault, check my help thread request above

[ol]- Exact CIS version & configuration:
? as said on line 3 above, out of the box setup, no changes

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    ?no changes from default
  • Have U made any other changes to the default config? (egs here.):
    ? No
  • Have U updated (without uninstall) from CIS 5 or CIS6?:
    ? No
    [li]if so, have U tried a a clean reinstall - if not please do?:
    [/li]- Have U imported a config from a previous version of CIS:
    ? No
    [li]if so, have U tried a standard config - if not please do:
    ? N/A
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    ? 7 Home premium SP1. UAC - default, admin, Vmachine =0
  • Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
    a=? Nilb=?Nil

I hope you can help me with this before I un-install and try a different product


Okay, let me know if the below steps correctly summarize what happened.

1: Remove older version of CIS by following the methods described in this post:

2: Then install CIS.
3: When installation screen pops up go to “Customize Installer”.
4: Uncheck Comodo Dragon and then continue with installation.
5: Comodo Dragon is installed with CIS even though the box was carefully unchecked.

Is the above correct?

Thank you.

HI, not quite correct.

  1. Installed on brand new windows 7 install, but due to dragon nag screen, followed procedure to remove as per thread.

  2. Install CIS

  3. Correct

  4. Uncheck comodo dragon, geek buddy and privdog - correct

  5. No, it never installed, but I get the nag screen installer window as per thread I linked to above


Okay, can you please post a screenshot of the nag screen you are seeing to your first post?

Also, I assume that Comodo Dragon is not currently installed. Is that correct?

Also, this sounds to me like there may be some leftovers causing problems. To rule this out as a possibility, please once again remove CIS by following the advice I give in this post. Then, while still in Safe Mode, but after you ran the removal tool for CIS, open your C-drive. Then go to Users => ‘your user-name’ => AppData (note you may need to show hidden folders to see this). Then, once you are in the AppData folder look through all of the folders. If any of them mention Comodo remove them (assuming you do not have any other Comodo software on your computer). If you do have other software then specifically make sure you are removing only the folders marked as Dragon.

It’s possible that there are remnants which the installer is detecting, which should have been removed previously. Once this is done, and there are no folders related to Dragon anywhere in the AppData folders, make sure all folders are also removed from the Program Files folders which are related to Dragon.

Then, restart your computer. Once it has restarted run a registry cleaner and remove all detected entries. This will rule out the possibility of leftover registry items causing this behavior. I would advise using Eusing for this, but it’s really up to you.

Once all this is done please once again try installing CIS. If the nag screen still shows up then this certainly does seem like a bug to me. However, hopefully removing these files will be able to solve this issue.

Let me know what you find, or if you have any questions.

Thank you.

Hi, the nag screen is as follows

This sits down on the task bar minimized and is glowing or pulsing, so when I click on it, that is what I see. I have clicked no many times, it goes away for about 1 minute. I have also clicked yes, it then launches the installer and I get the option of saying yes or OK to install or cancel to not install. Regardless it only goes away for about 1 minute then is back, it ignores my answer.

AS for following your link above and uninstalling CIS, I have done that exactly as above earlier and it was fine until the updater ran on connection to the internet THEN the nag screen started, it is downloaded first.

Just for the record, I have tried a few ways to rid myself of the nag and somebody posted on another thread to download AUTORUNS.exe I did so, ran it and found the specified item of concern dragon_updater.exe in the Task Scheduler. I unchecked this and restarted windows and it is gone, yeehaa.

It is a roundabout way of cleaning it up and I still say the CIS installer is not quite ready for the general public. but at thsi stage I am just happy to have it gone :slight_smile:

Because of that, I cannot help anymore in this thread, unless I feel weak(or drunk) and do another un-install just for fun :slight_smile: The weekend is here so stay tuned!


Hi TravellingStrom,
I was looking more into ‘dragon_setup.exe’ as we mentioned in the discussion topic.
The ‘dragon_updater.exe’ is possible caused by a partial install/uninstall of Dragon.
You could check to make sure the ‘Dragon update service’ has been removed from Windows services (Services.msc).
If it is still present without Dragon, it could be deleted from the services.

Kind regards.

TravellingStrom, was the advice I provided, or the advice captainsticks provided, able to solve this issue on your system?


Hi all, the fault was fixed by using the AUTORUNS program, thanks Chiron

As the HDD died on the laptop over the weekend, I have just finished re-installing windows 7 Home. I then used the same installer(saved to a USB stick) to install CIS, once again de-selecting all except the FW and AV.

This time everything went as planned and I get no nag screen, so I guess captain sticks may be correct in his prognosis.

Cheers to both of you


I’m happy to hear this is solved. In that case I will move this to Resolved.

If there are any other issues please be sure to let me know.