Dragon Keeps Crashing

Specific symptoms of the bug and steps you can take to reproduce it (step by step). open dragon → open any site → while the page is loading open a new tab. dragon becomes unresponsive and i have to terminate it
Specific steps you have taken to try to resolve it. n/a
Comodo Dragon Version (Stable/Beta) e.g. Dragon (Beta); e.g. Dragon (Stable) Stable 17.3
Plugins/Themes installed in Comodo Dragon adblock plus beta. (i have tried disabling the extension but doesnt help, i also tried uninstalling but dragon becomes unresponsive everytime i close the options window after uninstalling adblock then when i restart dragon adblock is still there.)
Windows version (w/ 32 or 64-bit) e.g: Windows 7 Ultimate (64-bit); Windows XP SP 3 (32-bit) win7 pro 64 sp1
UAC status (diabled/enabled) if it applies to you [ for Vista/Windows 7 only! ] disabled
System Drive where Windows is installed (e.g. C:, “C” Drive ) C drive
Place (installation path) where Comodo Dragon is installed C:\Program Files (x86)\Comodo\Dragon
User privileges (administrator, limited user, guest, etc.) admin
If you have Google Chrome installed then please mention it’s version and weather the same issue reproduces with it. dont have chrome installed

i used process hacker to create a dump file when dragon is unresponsive

for some reason it wont let me upload my dump file so if any of the devs want it just let me know

EDIT: i just realized the dmp file is 154 MB so ill upload it to ccloud and send the link by request

i have same system like you , and see none of the above.
my suggestion is try to uninstall dragon and than install it again with its default setting.

its a clean install of dragon. i had 17.2 beta, i uninstalled it using CPM then installed 17.3

i just did another clean install of Dragon and still having the same problem.

ok so idk if its a bug or not. i just tied to install 17.1 and am having the same issue. a couple weeks back it worked just fine. i cant figure whats going on, i cant think of anything that has changed that would cause this. any help would be much appreciated

Hi wasgij6,
When you have done reinstalls did you completely replace your user data/profile?
Just in case of a corrupted user profile.

i select the checkbox to delete user profiles then remove traces with CPM

What about any recent possibly corrupt or incompatible MS updates?
Also are you getting any windows event logs that have only recently started creating (Since this issue)?
Is the system showing any other recent symptoms or changes?

i cant think of any updates that would be incompatible. i looked through the windows events and didnt see anything even relating to Dragon or anything that would cause problems. this is the only issue i have had with my computer. im just wondering if it has to do with the beta. i had 17.1 stable installed then comodo released 17.2 beta so installed over 17.1 then 17.3 was released so uninstalled 17.2 and deleted any traces including certsentry. then installed 17.3 and have had problems since

Sorry I haven’t helped, I will continue to think about it.
Hope someone comes up with a solution for you.
I am not experiencing your problem and I did have 17.2 beta installed before 17.3.

no problem. i have looked through my filesystem and list of programs a few times just trying to think what has happened. if you or anyone else thinks of something let me know.

thanks for your help

if it helps anyone here is a complete list of programs i have installed

[attachment deleted by admin]


So far we’ve had no luck in reproducing the issue. Please check if the scenario reproduces with Google Chrome.

Thank you for your support.

yes this does reproduce in chrome. ill take screenshots of the problem details

[attachment deleted by admin]


Try creating a minidump when Dragon crashes and attach it. If you can’t create a minidump you can send a download link for a full dump file.

Thank you.

PM Sent

please let me know if you find anything

any update on this

finally fixed with v18