Dragon fails to download and install Adobe Flashplayer

The issue at hand is Dragon fails to download Flash. Dragon is running on a new Win 7 machine so there shouldn’t be any latent issues with respect to the OS.

Understanding that Dragon is a variant of Google Chromium and does not have Flash installed as part of its initial configuration, things appear to be straight-forward. When Dragon is first asked to play a Flash video, it sets a yellow bar at the top of the page with a hot button to initiate the retrieval and installation of Flash from the Adobe URL “get.adobe.com/flashplayer/”.

When I do so, Dragon and the URL interact with endless send requests and responses from Adobe. Upon closer inspection, the interaction appears to be endless requests answered by endless re-directs from Adobe (at least as long as I have let this interaction loop which has been quite a few minutes at various times of the day). Whatever the case, I can’t download Flash and install it from within Dragon. I have Dragon on at least 3 other computers (for a year or so) and have not had this problem in the past.

I tried to end run this problem by downloading the Flash installer with IE. I was able download and run the installation to completion with no glitches. Regardless, Dragon does not correctly incorporate Flash as a plug-in.

I have spent quite a bit of time trying to resolve this over the last day or so, but so far have not hit the magic sequence of operations to get Flash installed as a plug-in for Dragon. So I would greatly appreciate if someone who has has encountered this problem could offer up a solution so I don’t have to waste any more time on this.


Download the plugin-version from https://www.adobe.com/products/flashplayer/distribution3.html

Thanks, worked w/ no detours & no glitches.

I’m surprised that I couldn’t find anything in the forum about this before posting this message. I’m a tad skeptical that I’m the only one who has encountered this problem. Maybe my search skills on the web didn’t carry over so well here.


Internet Explorer uses one type of plugin or extension to play these Flash Player videos, but Firefox and Google (and Comodo Dragon) use another kind. In case you had downloaded and installed the plugin Flash Player for Firefox, it would already be present and ready for your Comodo Dragon. If you will check in your Control Panel and open your Flash Player control panel, you will be able to find both of these versions listed as installed. One is for I.E. and the other is for Google Chrome or Firefox or Pale Moon or Comodo Dragon (or SWR Iron…), …

My son & I are currently having the same issue. Flash Plug-in does not appear in the list of Plug-ins at all. Tried numerous reloads on Flash including the short cut listed above but still nothing.

I’ve submitted a report including a screen shot and hope it can be resolved. Seems to be some issues posted on here surrounding Defence Plus so may take a look down that route.

Fingers crossed.

Hi and welcome Dindleman,
Do you have other browsers that require flash plugin and do they work as they should?

This sounds like the problem I am having - I’ve rolled back to the previous version of Dragon, running the latest Flash and it’s working fine, and appearing in the plugin list.

I am having the same problem as Dindleman running on Windows 7 - I’ve downloaded both the standalone and plugin versions of Flash Player but they do not show up under dragon://plugins. I’ve also tried reinstalling them as well as reinstalling Dragon but to no avail. However, Flash works on all other browsers (IceDragon, Firefox, Chrome, Internet Explorer, and Safari).

I will have to try using an older version like FFsaki did.

UPDATE: I downgraded to Dragon v 22.0 and can now see Flash content ;D

I have had the same problem too. I’ve tried installing various versions of adobe flash, etc. but it doesn’t matter because in the plugin/extension list, adobe flash is not visible so it can’t be enabled. No matter how much you install flash, CD does not recognize it whatsoever.

I’ve tried fixing it a million times and finally decided to install an older version of Comodo Dragon. This fixed my problem so there is obviously something wrong with the new versions of Comodo Dragon.

oh this was so pissing me off… I installed the latest plugin version at least a dozen times but I kept getting told by dragon that my flash was outdated. The solution finally was the same thing that cured my stuttering audio on chrome(which is what led me to dragon)

when I went to dragon://plugins I noticed that my flash as some absurdly low version 9.0 r28 and it wouldnt update or change no matter what I did. Then I noticed the answer to stuttering audio in chrome was that there were multiple instances of the flash plugin installed and you needed to turn the excess off. Sure enough upon looking there were TWO flash plugins listed, the old one and the updated one. disabled the old one and VOILA. Issue solve… I registered on these forums specifically to save someone else a few hours of frustration.

Sounds like I need to roll back my version of Dragon and disable automatic updates? Hope this will be resolved in an update but odd that it seems to be so affecting so few users? =\ (BTW … IE and Chrome all play Flash content fine, haven’t tried Firefox or the Comodo variant)

Rolled back to v22.1 at File Hippo and ‘Taddah!’ Flash and the million other (well, 15 other) plugins missing in the latest version are all back! =)

Have disabled auto update, so keep getting pestered to update by message windows but will resist until v24 of Dragon comes along. Obviously something amiss with v23? =\

Glad you guys replied as I hadn’t thought to roll back Dragon (although I did roll back Flash! … Duuur!!)

Still no reply to my ticket BTW, so guess this isn’t as well known a problem as it might be?

Thanks to all contributers and hope your problems are all small ones! =)

Thanks JoWa, your solution fixed the problem for me. I just installed version 31 of Dragon and could not get Flash to update.

Thanks again!