Dragon extension's bug after update to


I have experienced a strange BUG in newest updated version of comodo dragon
I use Adblock plus, ghostery, disconnect and Lastpass extensions.
After update to latest version, when I shutdown comodo dragon and start it again adblock plus, ghostery and lastpass extension (disconnect does’t have any options to edit) restores it’s self to default settings, loosing all of my selected settings for each of them.
Comodo Dragon settings remain as configured by me.
OS is Windows 8 proffesional X64 RTM, and problem wasn’t present to pre-update version of dragon.

I tryed to uninstall comodo dragon and delete all setting releated to it including profile, dumped all TEMP folders.

This problem has been reported in several different threads.
The solution, until Comodo support realise it has a problem with the latest release, is to revert to the previous version, if you have it.

The same thing happens to me, it reverts to when you first installed the extensions and all the first run webpages load again and again

This problem is now impacting multiple Extensions on Multiple hardware systems as well multiple Windows installations & reported in other threads.

I allowed CD to update my Sony VAIO running Win7 64bit Home Premium, having reverted my Desktop Win VISTA Home Premium 32bit to the previous CD, to stop the problem, and now my VAIO is also having the same problem with multiple Extensions.

All the symptoms are pointing to this release of CD as the problem ?

I am reverting my VAIO to the previous CD version & also turning CD ‘Auto Update’ in Settings…OFF on both my systems, until CD Support offers another solution…if ever!! :-TD

I’ve switched to chrome until this ■■■■ goes away, I tried version 20 and it still did it which is strange.


The issue is related to the “Clear cookies and other site and plug-in data when I close my browser” option.

Please find this option at dragon://chrome/settings/content in Comodo Dragon and disable it. A fix will be available in the next release.

Thank you.

@ George-Silviu Blendea…

The author of AdBlock suggested this fix, but it’s not the problem.
I already tried it & the problem persisted.

I have reverted to V21.2 to overcome it!

@ Gator…

See my last post re the suggested fix…

Hooray!! V22.1.1.0 seems to have fixed all my problems…thanks guys.

finally it’s fixed in
I tried to run icedragon but mozilla memory leak is terrible !!
CD now runs as it should