Dragon cannot run in virtual mode

Great to see you involved with the nuts and bolts.

Here is a question you might be able to facilitate an answer for…

I use Version but when I select “Switch to Virtual Mode” Dragon simply closes. I have tried uninstalling, rebooting and cleaning the registry and then rebooting and reinstalling dragon and still it simply shuts down.

I use 64 Bit Win7 and Comodo Internet Security Premium version 5.12.256249.2599 with Sandbox enabled.

This probably means that I am missing/doing something really simple that causes the above issue.

Any clues??

Hi Topcat2456 and welcome back,
You require Version 6.X (2013) of Comodo Internet Security to run Dragon in virtual mode.
Using Comodo Dragon in Virtual Mode

Kind regards.

Been there. Must have missed something - but it does say “If CIS is not detected, you will be offered the opportunity to download and install it.” - and as I said, Dragon just closes.

I guess this means that I will have to uninstall CIS, download whatever it is called now, and install a different version. But surely i should not have to do this with the version number I now use?

I was hoping to avoid this.

It must be detecting CIS but not realising it is an older version soon enough.
This is probably what I would call a minor bug.
Sorry it will not run with anything under V6.X.

I guess this means that I will have to uninstall CIS, download whatever it is called now, and install a different version. But surely i should not have to do this with the version number I now use?
If you want to Virtualize Dragon yes you will, but please have a good look at V6 before installing as there are many changes and it is very different compared to your current version. [url=http://help.comodo.com/topic-72-1-451-4685-Introduction-to-Comodo-Internet-Security.html]CIS V6 Help[/url] [url=https://forums.comodo.com/news-announcements-feedback-cis/comodo-internet-security-612768672813-released-t93978.0.html]COMODO Internet Security 6.1.276867.2813[/url]

All the best if you decide to go ahead, alternatively it will be offered through the program updater in time to come.

Thanks for your help. I installed v6 at work and prefer the older version (listed in my first post), so did not update at home. I think I will wait.
If I have a problem with Comodo it is that they bring out a good program, and then replace it without any easily discoverable explanations (finding stuff in the forum is very time consuming and one has to be dedicated to the task rather than live a life…
They have also gone down the Symantec track with nothing ‘programs’ that are in effect a marketing tool (eg Cloud scanner and PCTuneUp) and a waste of time to download and install. There is so much Comodo could do to prove they are better than the rest, but no, they insist on joining them despite all the pontificating. Economic rationalism wins again.

You are welcome.
Just a note about V6, keep an eye on it as there will be some quite substantial improvements and especially to a more functional summary screen in the very near future. :slight_smile:

All the best from Captainsticks.

I waited and there have been a couple of automatic updates since our emails but on checking CIS says that i am fully up-to-date and that the version is 5.12.256429.2599 but you are talking version 6 etc. What is going on with the auto update system? On one hand I am receiving updates and on the other you are telling me that my version is way out of date.

Hi Topcat2456,
Automatic updates are not sent to 5.X users.
You can upgrade using the link below.
UPGRADE now from 5.x to 6.x
More information about updates in the OP of the below topic.
COMODO Internet Security 6.2.282872.2847 Released!

Kind regards.

Is Virtual mode a Premium only feature, because I have the latest CIS version, but cnnot run virtual mode with my free product?

Premium is the free version, and yes, it can run virtual mode.

It will not run Dragon virtualized if you are running Windows 8. It works in all other Windows versions. Hopefully this will be fixed soon.

I’m having the same problems. When I run ‘Virtual Comodo Dragon’ from the desktop link nothing happens. In Task Manager I can see Dragon and virtualkiosk processes running. When I end task and try again, I still get nothing. Comodo Dragon works fine un-virtualised though.

I have a similar problem too, although after about 40-60 seconds the browser does eventually open. (this is only the case after boot up) after this if i close and open again it is fine. As with you the normal un-virtualised browser opens instantly.
Any ideas as why this is happening??

Intel Pentium E5800 @ 3.20GHz
8.00GB Dual-Channel DDR3 @ 401MHz
Windows 7 Home Premium 64,
Comodo Internet Security 6 premium, MBAM on Demand, Comodo Dragon