Dragon Class not found bug. In Windows 8

If i use Dragon as default browser i get a class not found message in some applications that need a internet connection. If i change default browser to Internet explorer the error message dissapers.

Strange issue

When I pin a shortcut to the task-bar. Receive this error. When I execute from Classic Start Menu. Works fine. ??

[attachment deleted by admin]

Please try

Worked for me. Thanks.

Thank you for reporting this airborne and posting a fix Abyr, I wasn’t sure what to make of this when it started happening the other day. I guess Dragon updated itself in the background.

Deleting the 3 registry entries worked for me!

Wish I saw this topic sooner. I had the same problem when Dragon automatically updated itself to v25 from v24.
Outlook 2013 said Class not registered.
SimCity (updater) when clicking on “View Updates” said to make Dragon the default browser, even though Dragon was already the default. Switching to Internet Explorer fixed opening the link from the updater. Switching back to Dragon gave the error again, even though I ensured HTTPS and HTTP protocols were selected to use Dragon.

I uninstalled Dragon and am currently downloading v25’s setup. I hope all future updates will work and not remove these “Classes” that Outlook 2013 complained about when trying to open a link. I’ll go back to Google Chrome if these update problems continue in the future. It’s pretty much the same thing, but never had a problem with updates.