Downloads are so SLOWWWWWW

I downloaded and installed V3 today. I previously had CA Internet Suite and it was atrocious. So far Comodo seems to be working very well except for one thing: I went to download AVG 8.0 to use as my antivirus tool and noticed I am unable to download anything. I couldn’t find my answer here in these forums.

Network Defense is on Safe Mode
Proactive Defense is on Clean PC Mode


I use FireFox 3 and have added it as a trusted application.

I also tried to download other files besides AVG and got the same result.

I then tried to download these files in IE7 and get the same results.

As for numbers and specifics, the AVG file is about 46 meg and both IE7 and FF3 show it will take between 13 hours - 1 day to download at 100-400 bytes per second. Yes, that’s right… bytes, not kilobytes.

I have cable modem so that should not be an issue.

Comodo doesn’t have a web shield and does not interfere with downloads or browsing. Try making IE and FF a web browser in the firewall. Go to Firewall\Advanced\Network Security Policy and edit IE and FF from the predefined policy’s and select web browser. There are tons of complaints about AVG. What other security policy are you using?

I have made FF3 a web browser as suggested. It seemed to help at first but now it’s hung up at taking 1 hour and 20 minutes to download the 46 meg file (it downloaded 208kb quickly then pretty much stopped).

You say CFP doesn’t interfere with downloading but if you have to create settings then it DOES, doesn’t it?

I also need to make clear that I am not using AVG yet. That’s what I’m trying to download. So if you are suggesting AVG has issues then can someone here please give me a good alternative as a FREE antivirus program?

What other security policy are you using?
Not sure what you mean here...

Exactly what I said. What other security programs are you using? Antivirus,Firewall,Virtualization? Avast is a great free av. NO Comodo doesn’t interfere with web browsing. Those policy’s are for security. You can make it trusted if you want. When is the last time you cleaned out your cookies and temp files? Have you tried restarting your modem/router? Have you tried a speed test?

What version of Comodo are you using? Are you using any 3rd party downloaders?

Again, I was using CA Internet Suite (which included Antivirus, Firewall, etc) and I deleted it all so I have no other security programs running.

I am using FF3 as my browser. Everytime I exit it clears all those items you listed. I have made FF3 trusted already.

No, I have not restarted my modem/router. Should I? Why?

No, I have not conducted a speed test. I am having no issues surfing the internet, only in downloading things.

I guess I’m just surprised that it is this difficult to get this thing working.

I am using version

Hi ballegator,

I have recently removed CA internet security from a computer and it was a …!
This is not what you want to hear but it ■■■■■■■ up the system so much i had to re-format.
You need to make sure all of CA is gone but the help in removing it,ie where to look what to remove is not great :-TD

If you open task manager do you see anything of these,capfsem.exe,ppctlpriv.exe,Umxfwhlp.exe,Umxcfg.exe,cavrid.exe,qofloader.exe,capfasem.exe,vetmsg.exe,ccprovsp.exe,isafe.exe,cctray.exe,Umxagent.exe,Umxpol.exe

These are the running procesess for CA


I know 1 word on that: “Lies”.
If you got a problem after you download and install a program, either:

  1. The program causes it
  2. Some virus/rootkit/etc has snuck inside

It is that simple, Comodo 3.x did kill .NET applications. I guess that was never the purpose, so i guess there is a small error that caps the downloadspeed in the program. It was never meant to be either, so whoever made it would not know this.
It is like you accidently create this grand backdoor to your PC, and you scripted the program. You would not know until you check the program.

So you want to comfirm Comodo is the error? Easy! Uninstall it(then restart) and check the speed for downloads, if it now works as it was suppose to do… We KNOW what caused the problem :stuck_out_tongue:


So what caused the previous 14 fatal errors?

Comodo 3.x… How do i know this:
*A normal Windows should not have any trouble with this, i installed it on a clean PC once before too.
*Fatal errors appered after 3.x
*After i uninstalled 3.x i could suddenly use what previusly caused fatal errors
*I installed 2.x and it did not have any error wither
*Uninstalled 2.x and entered in 3.x and got the errors again.

PS: i use .x because i do not bother finding version number <.<

NB: kind of like figuring out what mod is killing your game, and what conflicts. It takes time and is troublesome, just happend to figur out what caused it on first attempt. Bless luck :stuck_out_tongue:

I have installed Comodo on 10 XP machines with no troubles what so ever.

Ok, I uninstalled Comodo just now and tried a download again. Same issue, very slow/non-existant. So it’s not Comodo. Now my question is how do I find out why I suddenly can’t download anything?

Call your ISP. Shut down all security software and see what happens. Glad to see its not Comodo.

It might be worthwhile to check some things, to see how your machine is running.

Open the Windows Task Manager by pressing ctl-alt-del.

I’m going to ask for three screenshots. To make a screenshot, press alt-prntscrn to copy the window image to the system clipboard. Open Paint (Start → All Programs, Accessories, Paint), and cntl-v to insert the image, and save as a JPG or GIF file. Then attach that file in your next posting.

Select the Processes tab. Resize the window so you can see all of the processes listed without having to scroll the list. Then take a screenshot to post here.

Select the Performance tab, and make another screenshot.

Select the Networking tab. and make another screenshot. It may be better to wait for the graph to have some squiggles all the way across, so as to better understand what kind of loading your machine has.

If there is something taking up resources on your machine, it should be apparent in one or more of those screenshots.

Also, how are you connecting the Internet? With a NAT/router or directly thru a modem? Wired or wireless?