Downloading virus update stalls at 50%, "Skip Update" doesn't skip the update

CRD 2.0.275239 and Neither will start the GUI and neither will get past updating the virus signatures.

I can’t get the GUI to launch booting from USB or DVD.
I caught something about a conflict with the video as CRD tried to start up in GUI mode. It was too fast to get the whole error.
If I run the program in a virtual machine on the PC, the GUI works.

The text version launches with these issues:
If I choose Smart Scan, it goes to Downloading: the status bar reaches 50% Nothing happens after that.
If I try Custom Scan choose “Critical areas and boot sector” and “Don’t scan for viruses” and I get
Update Failed
Back, Skip, Retry.
Skip sends me back to the main menu. Retry attempts the download and it stalls at the 50% mark.
If I do a full scan and skip the update it works.

The last comment on this forum was over a year ago. Is there something I’ve missed going through all the posts?

You are not alone. I can’t find a solution about these problems either…
Does anyone has any idea how to solve at least the update problem?
I try to update the database manually from text mode, but it doesn’t see the .cav file in the directory.
Any solution about that?