Download Comodo software problem

What’s happening with Comodo downloads
When clicking the link to download Comodo Internet Security (and other software from comodo) it asks for a user name and password, and without that password the access is denied.

Everything is fine here…

No Issues Here;

What product are you trying to download?
Also; Can you Follow This Post Here

OK, the problem is with my router.
Somehow it is kind of incompatible with comodo servers, since this only happens when downloading any of comodo software.

I’m curious here, but does it happen to be a Belkin router?

Comodo is working on her servers. You may be witnessing that.

I tried to download from this site, but nothing happens…
What can i do?

It works here too.

hey, i still can’t download comodo cis from its website,what’s wroung with it???

Not CIS but I had problems downloading 2 other comodo software from here using both Dragon and IE.

What helped is when I ran a Winsock fix program. Not sure what OS you are using. Do a search for Microsoft Winsock fixit, Microsoft has several fixit files.

Still not sure why?


By the way, Winsockfix only works on Windows XP.

are you sure about that? iv had to do it on my win7 machine to fix cnnectivty issues

Windows Vista had a completely new network stack which is also used in Win 7.

Winsockfix is a tool to reset the XP network stack. This Microsoft KB article describes how to manually reset network stack in XP and Vista: How to determine and to recover from Winsock2 corruption in Windows Server 2003, in Windows XP, and in Windows Vista - Microsoft Support .