Domain Permissive Interface Not Working

I am testing Comodo Secure DNS, but I frequently run into a recurring problem: the Domain Permissive Interface does not work!

Occasionally, when trying to access a web site, I will be presented with the “Warning: Unsafe Website Blocked!” screen. I will then click on the “Disregard” button.

Next, I am presented with the “Domain Permissive Interface” screen, whereupon I select to allow access and click on the “Continue” button.

Next, I am presented with another “Domain Permissive Interface” screen, informing me that I can now continue to the web site by clicking on a link, or wait to be redirected to it. At this point, one of two things happens:

  1. I get stuck in some kind of infinite loop where I am presented again with the “Warning” screen (above), or
  2. the resulting page, after either clicking on the link or waiting to be redirected, is blank.

What is going on?! Also, please inform me how to disable these warnings while continuing to use Secure DNS.

Thank you.

It doesnt work from a lot of time ago.

Try this other comodo dns ip pair: -

Heavens to Betsy, why is it still broken? A lot of Comodo products seem to run amock. Start with great fanfare, then die a slow death with features that never worked or never get fixed.

I give up… again… I found the same problem, and discovered you have to "LOG IN " the second time! Top right of the page - Otherwise you will wait … forever… and nothing will happen.

Its a bug, I guess… and that’s why we’re here. To report them.

By the way, you will have to manually enter the site you want to unblock again. Plus, IT DOES NOT TAKE YOU ALONG TO THE SITE, you have to skip back several pages or just go find it again. Spelling typo’s are STILL not corrected after weeks of notification to Comodo. Its Permanent, NOT Perminiant