Direct Keyboard Access from trusted Aplication

Hy, i have a trusted aplication (that i already added as Safe File in Defense+ and Exclusion on AV) but the Defense+ still bocks some how the Aplication, i cant use the clipboard on that aplication.

How can i make the COMODO ignore this aplication without having to turn off the Defense+ ?

[attachment deleted by admin]

mark mIRC as trusted, in defense+ setup.

Already did that, that’s why i think its a bad BUG because if we mark a file as trusted it should not be blocked.

Any solution?


bump #2

Set the defense+ strategy rule of your application to custom.

Click for the concerned application modify, access rights, set the 2 appropriate check buttons to allow.

I have the same issue (+ more…) but with outlook.
I am using the latest version of comodo firewall, 4.1.150349.920 on windows xp pro, 32bit, sp3 with all the latest security patches from ms.
I use MS outlook, version 2007 (12.0.6514.5000).
The full path to the outlook executable was added as a trusted file to the defense+ rulebase but it doesn’t help.

  1. When I click a link to a web site, in a HTML mail message - I get an error dialog box stating “general failure. The URL was: “”. The system cannot find the file specified.” - but the link DOES open in my browser so there is only this annoying error message.

First I tried to workaround the issue by uninstalling the component of ctfmon.exe (see in but it didn’t help - Now the error is about outlook accessing csrss.exe, a windows component, which I can’t remove… :wink:

  1. Another issue with outlook, more problematic, is that you can’t paste any text from the clipboard memory into its sub-objects (like a new mail message you are writing or a new appointment you are creating) - the error in Defense+ is because of “direct keyboard access”.

The only way both this issues can be resolved is by disabling BOTH defense+ and the sandbox. disabling only one is not enough.
So, for now defense+ can’t be used to make any actual protection, until this is solved.

Please, can a comodo official response here?


[attachment deleted by admin]

I want to chime in and say that this problem is still happening. My browser keeps getting flagged in the log with ‘direct keyboard access’, even though it’s a trusted application or with a custom rule with ‘keyboard’ allowed.

I also keep getting ‘dns resolver’ flags, but I guess that’s another issue entirely.

Either way another Comodo update gives me a gigantic headache as usual, why can they never go smooth? If this keeps up I might get rid of the firewall entirely.

I opened a support case about this and they answered this:
We have forwarded this issue to our developers. We will get back to you as soon as our developers provide us a possible solution for this issue. Kindly bear with us till this time.
So, a cure is on the way. hold on…

To resolve the memory access problem:

Select Defense+ -->Advanced → Computer Security Policy.
Scroll down to Comodo Internet Security, select Edit → Protection Settings.
Interprocess memory Access (Active Yes) select Modify → Add -->Now use Running Processes or Browse to point to the concerned file(s) .
Then just “Apply” to each window as you exit.

The above method can also be used for the other mentioned problems. Just substitute Memory Access with Send Message or Direct Keyboard Access.

The problem is, that doesn’t work.

It has done for the memory access problem (although even that problem returns randomly), but not for any other. I still get locked out of using the keyboard in my browser, or programs aren’t allowed to launch other programs via ‘com interface’, and programs that use the net set off DNS flags in the log. It doesn’t matter if I make these programs access these functions like you’ve instructed, or make them trusted applications, nothing I do resolves the matter so I’ve just turned D+ off.

Can you show the message you get, screenshot, in the D+ logs for the key board and browser? Are you using the sandbox?