Dinput.dll [Resolved]

Ever since the M$ updates (surprise surprise), I’ve noticed a alert for dinput.dll whenever I use programs like Utorrent (only after the download is finished) or transfer files through IRC (least I think the latter is correct, I haven’t actually transfered anything in awhile and my memory of that pop-up is sketchy). After which, if I hit deny it tries to hook itself through FF (see attachment) My own research into dinput.dll says it’s for input devices, so I’m wondering what is going on with dinput.dll (scanning the file in system32 with avast and viruscan.jotti shows a clean file)?

[attachment deleted by admin]

For one do you own any media devices i.e. joystick?

Nothing in the ways of devices on my end outside a keyboard and mouse.

Why don’t you backup dinput.dll to another folder and then delete it and download a new one?

have you looked at this copy of dinput.dll on your computer to see what information it may provide you? Such as if it’s from MS, joeblo or whoever, etc…

MS forums have told people with similar questions to reinstall the file from the last SP, as it’s part of the OS. Everything seems to indicate it should be a normal part of the OS. Don’t know why it’s messing with you, but we all know by now that those last MS updates were a real ■■■■■■.

LM

PS: BTW, I did a google search on “dinput.dll” and your post was in the list of references it brought up… You’ve gone big-time with this! ;D

It’s definitely from MS alright. But checking it, it seems that it’s unmodified according to properties. Nothing seems ■■■■■■■ up, it’s just something triggers explorer to insert dinput after using the mentioned programs. A search also shows only three files with the same name, all of which seem fine (dinput.dll, dinput8.dll and a folder called dinput in directX). Maybe I should raise this question with Utorrent.

Ps: Not the kind of attention I’d like wink

[attachment deleted by admin]

There’s a whole list of “dinput” files that go along with it; dinput8.dll is one of them. It all relates to directX, as I understand it.

I have noticed before on some system files that after there is a massive update that changes everything, individual files may still show an older date (such as 2004) when it was created, instead of a Modified date related to the recent change.

That’s not much of an answer, I know. Have you tried (yet again) uninstalling/reinstalling CFP in Safe Mode to see if that would resolve it? Or do you even want to mess with that route? :wink:

LM

Meh, I’ll try uninstall/reinstall again, though I do suppose I’ll be needing something to transfer… I’m not going to scan though, that just brings back…unpleasant IPS SVChost pop-ups that have quieted down.

edit: Okay re-installation complete. Oh and I mis-targeted the comodo scanner as the culprit, it seems reestablishing my internet connection for the first time after a comodo installation triggers like 3 pop ups to my IPS. There wasn’t a “go to ****” option since they all count as svchost/services, so I just denied for one to deny for all.

edit2: Okay transfers through IRC seems to be a-okay. Will try torrenting/seeding when there’s something worth torrenting/seeding (probably tomorrow).

Hey, wait a minute, I just realized that I already did a reinstall after the updates to try to sort out the svchost pop-ups (yeah you did mention it, but I’m slow like that). Since both these issues are post-update, if it didn’t work from that time, won’t it not work this time either? Well, we’ll see in half an hour, because I’ve found something to torrent.

edit: didn’t work, got it again, except this time the torrent didn’t even make it to seed. I plugged in my external hard drive and switched it on and the pop-up showed up, maybe utorrent, explorer, and my external are interacting somehow, will test this. I took a screen too, but I accidentally forgot and ran CCleaner before I pasted the screen, bleh.

edit2: well there goes that thought, or perhaps it has to be finished or close to done or I’m uploading, well lets see.

edit3: It’s not the uploading part and I’m starting to suspect the external might be coincidental. Ugh, there doesn’t appear to be any consistency in this and it kills my internet to deny (though I do know the three finger salute via manager, so it’s no grave concern heh heh), so it’s kinda annoying.

Does plugging in your external drive and turning it on trigger it every time?

LM

PS: I’m surprise you went for the reinstall… I really honestly wasn’t trying to mess with you; I thought it might help but after all that I know you’ve been through, didn’t figure you’d do another in a million years… :wink:

No, I tried plugging in the external a bunch of time and switching it on with the torrent downloading that wasn’t the cause, it might’ve been a coincidence the last time, or perhaps it relates to percentage completed. I think the pop-ups occur around the end of the download (which is rubbish because the last one showed at 97% rather than the usual 100%).

Heh, I know you were only offering suggestions that you considered helpful, and I thank you for that, it’s just I pieced two and two together after the reinstall and was merely bring up that realization. Besides, all I’ve been through are minor inconveniences, which upgrades to inconveniences if this thing pops up at 97 every time I try torrenting.

edit: Okay this is weird, I just got through a torrent all the way to seed mode, without the thing popping up. I’ll keep my eyes open, but at the moment I have no idea what gives with dinput.dll at this point, I’m sure it’ll happen again but the timing is now off along with consistency, BAH!

There’s a free application called What’s Running; it might help you tracking down the process that owns the dinput.dll thing when it’s called. It doesn’t install, just runs from downloaded executable. That might help…

LM

I remember that program, I also remember that it has an installer, do you mean TCPView which was the one with the lack of an installer?

I’m just going to lay and see, but if/when it happens again, I’ll take it up with the Utorrent forums and see what’s going on, seeing as how Utorrent somehow is the trigger (most of the time at least). Thanks for the assist though.

edit: Oh and when those pop-ups for dinput appears in Utorrent, there’s an avalanche in quantity, last time was 15, I’m guessing it has to do with the peers that are connected but I didn’t take a especially close look.

Nah, TCPView is only to view current connections. What’s Running shows a lot more. I’m attaching a screenshot to illustrate. The “Modules” tab shows all active dll files, and what process owns it at that point (on the right side). I just picked one at random (I don’t have a dinput.dll running, or I would’ve used that).

LM

PS: I did a couple quick searches on utorrent forums but didn’t get any results for existing topics/posts.

[attachment deleted by admin]

I’ll put what’s running back on and wait and see then, alright hopefully we can get something to examine. I imagine I’ll have to allow the next time there’s a pop-up. Hopefully I can get something useful for examination, thanks.

Yeah, just allow w/o remember, so no rule will be created. That way you can see all the details; whatever they may be…

LM

Alright got another pop-up (Didn’t screen the pop-up, but I took a shot from the log):

This time however the pop-up did not occur while I was using Utorrent (rules out that thought, ugh), but my external was connected so I’m looking at that again (it’s a maxtor onetouch 3).

Immediately after I allowed, I ran what’s running, but I didn’t see any entries for dinput in modules.

[attachment deleted by admin]

You know, I was scratching my head wondering why you were getting an alert for this going into explorer.exe, as that’s the Windows shell, and the entry doesn’t mention any other application (like browser). Then it hit me! This is a loopback issue (localhost 127.0.0.1) which applications use for internal communications.

If you are not using a local proxy server, you do not need to monitor these loopback connections. You may go to Security/Advanced/Miscellaneous. You will find two entries for “Skip Loopback” - one TCP, one UDP. Make sure they’re both checked, and OK.

This being a loopback issue clears a lot of things up, from my perspective, as this is a local/intra-computer connection - this communication isn’t something that is leaving your machine.

LM

I guess it would’ve saved us a lot of time if I didn’t black out the IP from the start, sorry about that. I also hit me after I got the pop-up to look up the IP address, but since I’m pretty tech illiterate I’d figure I’d wait for an explanation as well before I started doing anything else. No idea what a local proxy is so I’m going to assume I don’t have it, okay thanks for the details, I’ll be sure to switch skip loopback on.

Bah another one. While, the others were probably mostly loop backs, this one I have no idea. I read that dns is for translating websites, and the IPS is what I believe to be part of my ISP, but I’m trying to figure out why dinput would be loading in this case?

edit: Seemed to have occurred after I opened a file from the external with media player classic.

[attachment deleted by admin]