Digital Email Cerificate

I have managed to put the Digital Signature in the trusted folder, it shows up under my name but neither T-bird nor CSE will recognize it.
Under Certificate Information it says this.
A certificate contains an unknown extension that is marked critical.

I assume something happened during download and installation process and that it is corrupt and I probably need a new one. Am I correct? I am using Vista HP 64bit.


It may simply be the case that the certificate needs re-installing.

Right click on Internet Exporer and click (Properties). Click on the “Content” tab and then click Certificates.

Click on your certificate and then click “Export”. At some point you’ll see a tick box saying Delete after export. This will remove it from the installed certificates.

Now located the certificate you just exported and double click on it.

Select YES to install the certificate and follow the prompts. You’ll have to input your certificate password during this.

Reboot your machine then check that it showes up in CSE and that it’s installed in TB.


Hate to tell ya this but it was downloaded in Firefox.
I did what you said in it and that is a no go.

Would this be it?

That’s not it the certificate will end in (.pfx)

Have you tried exporting and removing it from Firefox and then installing it as I’ve previously described?

Did your certificate download properly?

P.S. You could also try manually importing the certificate into TB and CSE.


The only way I can find it in firefox is to open, go to tool, options, advanced, encryption, then view and there it is but it does not have an export button but I do have an option of deleting it.
I tried to import the copy I have in my documents and it would not import it and it said for “unknown reasons”
When I clicked on the email link that was provided for the download it said it had been installed.
When I click on the link now it says that it has already been installed.
P.S. your IE and mine are different. Mine has no content tab.
As for the manual import to TB I have done that but it will not recognize it. It is there when you click on view but it will not recognize it for some reason.

I am not familiar with T-Bird Email client. But I do have a digital certificate I use with Outlook 2007.
What do you have on your Secure Email options screen (or similar screen)?
Do you have anything close to ‘Add Digital Signature to all outgoing email’?
Also, 'Request S/MIME receipt for all S/MIME signed messages? There may be a ‘Settings’ button with this.
The default should be ‘My S/MIME Settings’ and your email address.

I am not going any further until I hear back from you.

under Security it has a place to digitally sign all email but first you have to provide a vaild certificate by pressing a buttom called “select” and that is when it comes up a message that it sees no valid certificate to use.
You can click view certificates at the bottom of that page and right there the certificate is but the nothing will recognize it. I see no settings called s/mime with my email address even under accounts.
If I remember correctly there is a tutorial on the t-bird home page maybe it would have something on it.
But not tonight. It is bed time.

I didn’t see anything in their tutorials concerning security and certificates.
Once the certificate is installed on a Windows system, it can’t be re-installed (as you discovered). I suspect the certificate just needs to be recognized in a setup window.
(My next step but if it isn’t showing up…)
There is a Forums on the site. May I suggest first ask there on how to get T-Bird to recognize an installed certifcate?

Please report back.

Why does the certificate say this in the extended key usage segment?
TLS Web Server Authentication (
I went back to windows live mail program to try to get it installed over there with the same result but I clicked on view and just kept clicking to see if I seen anything out of sorts and seen this. Is this an issue or not? I am over at t-bird’s faq’s section and I am learning quite a bit on the subject but haven’t ran across the acceptance/usage area yet. May have to post in their forum. But it is time to get moving. Have a nice day.

If you click open Windows Certificate Manager, what does it show under Personal Certificates?

It shows my certificate.
It has my name as issued to, my name issued by, Expiration date as 12/28/3008 and friendly user says none

‘Issued By’ should show UTN-USER.
This should be the same information seen from Comodo SecureEmail under Certificates, click Certificate Manager/Personal.

You still have the link to reinstall. From here you can remove the certificate to allow you to reinstall it.

Once you have the certificate installed and it is valid, you should be able to use it.