Dialogue box saying Comodo needs to close

Hi this is my first post here.

When Win XP SP3 Home starts, the Comodo icon appears in the Tray then from time to time a box appears as per attachment. But as far as I can see Comodo didn’t shut (icon doesn’t go). I’ve not always had this problem - which isn’t major - but anyone any idea why.

BTW this is the free Comodo firewall version. I also run Avast Home 4.8 free and SUPERAntiSpyware.


[attachment deleted by admin]

When you hover over the icon does it stay or does it go? When it goes it means that cfp.exe has crashed; that is the client program.

What happens when you push the debug button? Do you get information about the crash and instructions on how to submit it?

Don’t know about hover, not tried. But the program stays ‘alive’, so to speak, if I click the ‘OK’ button to get rid of the dialogue and the icon stays put for the rest of however long the computer is on (which is usually many hours). I did try the Debug button some time back but can’t remember what happened. Next time this occurs I’ll do both your suggestions and post again. Thanks

Keep us posted. What version of CIS are you using?

The free firewall only - according to the About box it is version 3.14.130099.587. Will inform.

When it crashes again can you check with Task Manager under the Processes tab which of the following CIS processes are running or not running: cfp.exe and cmdagent.exe?

My PC is a 7yr old Athlon 2400+ with Windows XP Home SP3. I have just had to reinstall Comodo CIS for this exact same problem. I would exit the pop up and Comodo didn’t close. When I opened up the GUI it said that I didn’t need to do anything at the moment as Comodo was working fine. However when I opened Task Manager I saw that only cfp.exe was running with no mention of cmdagent.exe. I came here and downloaded the Comodo clean up tool and a new copy of Comodo CIS, then uninstalled it from my PC. On reboot I ran the clean up tool then rebooted again and installed Comodo CIS suite again. Everything is working well now and the problem seems to be cured.

I haven’t had the ‘needs to close’ dialogue since I posted last. But today I did. Because I couldn’t remember what I needed to check for I left the dialogue open and sought out this thread again, which took a few minutes!

Both the processes mentioned are running in Task Manager. I didn’t hover over the icon until I read again that I should but it stayed put then (I’ve never seen it go without hover).

Pushing the debug button makes the dialogue go (although I was very late doing that as I was typing this).

Does that help?


I have been bugged with this problem again ever since I updated to v4. I eventually found that I have no problem when I uninstall/switch off the AV part of CIS. I then downloaded and tried Avira v10, MSE, Avast v5 together with Comodo Firewall, Defence + with sandbox switched off, Proactive security on and set up as 3.14. Over a week I tested the above mentioned AV’s for a 2-3days each and had various problems with them all, from Avira v10 starting up a couple of processes sched.exe and another one everytime it updated which could not be switched off again, to MSE being a typically intrusive Microsoft product again with bits of it which had nothing to do with the AV but nonetheless using lots of memory and no way to shut it off. Avast 5 I couldn’t even get to install although I tried five times. In the end I figured rightly or wrongly that there may be a conflict with Avast and Comodo although others seem to get them to work together.

                     I have used the latest version of Revo Uninstaller at the strongest setting to uninstall all these different versions as well as the Comodo clean up tool for Comodo and after a reboot a check with CCleaner and a manual deletion of all relevant program folders from the My Programs list and also from Apps & Settings with hidden folders open to get rid of the entries in All Users and my own files and settings folders to ensure I minimise any possible remnant conflicts.

I then added the Comodo AV to the existing install and almost immediately got problems with the bug pop up switching off cmdagent.exe which I found could be repaired via the diagnostic tool in More rather than having to reboot all the time. I was thinking this is possibly because I added the AV after the Firewall so this morning when I again got the bug pop up on signing in I decided to do a clean reinstall of Comodo CIs with a new download from here. I used the online installer rather than a downloaded one and everything went well and installed ok. When asked to reboot I opened my PC up in Safe Mode and switched off the sandbox, ticked my additional boxes etc set the Firewall to Training and Def+ to clean PC mode and then continued the restart. Once signed in I opened up all my programs and did a search for updates on those with this option in order to teach CIS and then in Firewall Rules set Firefox and IE8 as browsers, SpywareBlaster and SAS, MBAM which I only have installed as on demand scanners as trusted. When I was finished I set both Firewall and Def+ to Safe Mode and then I went online. Within half an hour I got the b****y bug pop up back but this time I happened to notice that the AV was updating when it happened and then realised that is the problem. For some reason the AV update is triggering this bug and switching off cmdagent exe. In the week or so that I tested the other AV’s using only Firewall and Def+ I never had this bug once but as soon as I use Comodo AV it happens. yet in retrospect it has probably happened during Comodos various daily updates. i am pretty certain this is the case in my instance.

Perhaps this is something to do with my set up ie, 7yr old Amd Athlon 2400+, Windows XP Home SP3 OS as some of the others with XP Home are also having problems. Until I find an AV that runs like Comodo Firewall and Def+ I will just live with this at the moment but feel that I am right in saying that the problem lies with the update and perhaps someone with more know how on these matters can offer up a solution.