I clicked “Diagnostics”. A pop-up box came up saying “The diagnostics utility has found some problems with your installation. Would you like to fix them”? I clicked “Yes”.

Another pop-up box came up saying “Failed. The diagnostics utility could not fix some of the problems. Would you like to create a diagnostic report”?. I clicked “Yes”.
I do not understand the report. I am unable to post the attachment because it exceeds 40000 characters.

How can I send it for review?

Thanks for your help

You can attached the report packed in a zip archive to your posts.

Here is how to attach a file. Push the reply button. Or when using the Quick reply type some text and push the preview button.

Underneath the text box click on Additional options. Push the Choose button and navigate to the file and select it. When you want to post more images click on the more attachments link.

When done typing push the Post or Preview button.

Before sending the report, I read another post with the same problem where the report mentioned “bases.cav=no”. I do not have Comodo’s anti-virus installed, only the Firewall like the other post and my report also mentioned “bases.cav=no”.

Also, occasionally, a white pop-up appears in the system tray saying “Comodo Internet Security 4 is ready for update”. I do not have the Internet Security installed, only the Firewall.

What seems to be the problem(s) and how can I remedy same?

Thanks for your support.

I see you must be running v3.14. The installer for v4 will give you the choice to install firewall only or firewall with av.

When running the v4 installer with v3.14 running in the background it will save your active configuration from v3.14. You can activate that after the installation of v4 under More → Manage My Configurations.

When Internet Security 4 first came out, I tried many times to install the Firewall both from the Download Internet Security site and the Download Firewall site but they were not successful. After your reply, I spent the last few hours trying again with the same results.

“Comodo Internet Security Premium Setup Wizard ended prematurely because of an error”.
When I tried again another pop-up “Error 1603: Fatal error during installation.”

I rolled back my computer and unless a solution is found, I would most likely have to install another Firewall.

May be you can find a solution in Installing kernel drivers → Rolling back action, Error 1603 (merged threads).

Also try Windows Installer Clean Up utility to get rid off Windows Installer left overs.

Notice that Microsoft discontinued it. Use at your own risk. I have used it to good effect in the past though.

I am having an issue with the diagnostics as well. Here is the file zipped

[attachment deleted by admin]

What version of CIS are you using? I assume Diagnostics cannot fix it?

When Diagnostics cannot fix it please try a clean install of Comodo. After rebooting use this clean up tool to remove possible leftovers. Before uninstalling you can export your active configuration (Miscellaneous → Manage my configuration). You can import this configuration in the clean install.

I have done the clean install. Uninstalled and used the CIS removal tool for any hidden traces, have included the report. So here is the report2. Just a little confusing, just wishing a little easier user friendly interaction with the program suite.

[attachment deleted by admin]

Again the .txt file shows as Chinese. It also happens when I use FF browser. Not sure what is going on with this… :o

Seeing the same thing here.

[attachment deleted by admin]

Other mods seen it too. Looks like a forum issue.