Diagnostics ( beta) [CLOSED]

I just installed CFP on Vista 32bit and while browsing around the interface I ran into something I found interesting.

On a clean boot if I goto Miscellaneous and run Diagnostics, it comes back and saying there are problems with the installation but will not let me fix them. I closed CFP by right clicking the taskbar icon and choosing exit, then restart CFP through the start menu and choosing run as administrator. Then when running Diagnostics no problems are found. If I then close CFP again and start it as a regular user I once again get the message that there are problems and it fails when trying to fix them.

I realize this is permission issue within vista causing this. However, rather than saying there are problems and failing to fix them you should be able to see if the program is running as administrator and if not prompt for the application to be run with those rights.

The same error occurs on Win XP SP2.


CFP BETA is now available for download!

Topic Locked