destination routes

Hello,

I am having quite some trouble getting this to work. Changing the mx part in cpanel is straight forward but i cannot get the destination route sorted out.

I tried
mail.hostingdreams.nl:25 but this should be outgoing and i only need it for incoming
mail.hostingdreams.nl:26 alternative outgoing port

and all ports listed below.
I either get

 Relay : mail.hostingdreams.nl:25
Error code : 550
Error message : Verification failed for <postmaster@spfcheck.antispamgateway.comodo.com> The mail server could not deliver mail to postmaster@spfcheck.antispamgateway.comodo.com. The account or domain may not exist, they may be blacklisted, or missing the proper dns entries. Sender verify failed
Debug output :
ehlo mta2.prod.casg
250-vps1.hostingdreams.nl Hello outbound.antispamgateway.comodo.com [178.33.199.67]
250-SIZE 52428800
250-8BITMIME
250-PIPELINING
250-AUTH PLAIN LOGIN
250-STARTTLS
250 HELP
mail FROM:<postmaster@spfcheck.antispamgateway.comodo.com>
250 OK
rcpt TO:<postmaster@hostingdreams.nl>
550-Verification failed for <postmaster@spfcheck.antispamgateway.comodo.com>
550-The mail server could not deliver mail to postmaster@spfcheck.antispamgateway.comodo.com. The account or domain may not exist, they may be blacklisted, or missing the proper dns entries.
550 Sender verify failed
quit
221 vps1.hostingdreams.nl closing connection

or

 Relay : mail.hostingdreams.nl:25
Error code : 500
Error message : SMTP host unreachable

With the without the mx records set. And when i just accept the settings, no mails arrive. In WHM it says

Event:	rejected rejected
User:	-remote-
Domain:	
Sender:	postmaster@spfcheck.antispamgateway.comodo.com
Sent Time:	Jan 7, 2015 8:25:20 PM
Sender Host:	outbound.antispamgateway.comodo.com
Sender IP:	178.33.199.67
Authentication:	unauthorized
Spam Score:	
Recipient:	postmaster@hostingdreams.nl
Delivered To:	
Delivery User:	hostin
Delivery Domain:	hostingdreams.nl
Router:	reject
Transport:	**rejected**
Out Time:	Jan 7, 2015 8:25:20 PM
ID:	1Y8wEw-000DHw-v6
Delivery Host:	outbound.antispamgateway.comodo.com
Delivery IP:	178.33.199.67
Size:	0 bytes
Result:	Sender verify failed

Mail settings:

Beveiligde SSL/TLS-instellingen
(Aanbevolen)
Gebruikersnaam: 	info@hostingdreams.nl
Wachtwoord: 	Gebruik het wachtwoord van de e-mailaccount.
Binnenkomende server: 	vps1.hostingdreams.nl

    IMAP-poort: 993
    POP3-poort: 995

Uitgaande server: 	vps1.hostingdreams.nl

    SMTP-poort: 465

Verificatie is vereist voor IMAP, POP3 en SMTP.
Niet-SSL-instellingen
(Dit wordt NIET aangeraden.)
Gebruikersnaam: 	info@hostingdreams.nl
Wachtwoord: 	Gebruik het wachtwoord van de e-mailaccount.
Binnenkomende server: 	mail.hostingdreams.nl

    IMAP-poort: 143
    POP3-poort: 110

Uitgaande server: 	mail.hostingdreams.nl

    SMTP-poort: 26

Verificatie is vereist voor IMAP, POP3 en SMTP.

So i am quite confused…

Most mail servers listen on port 25, 587, or 2525. I am sure there are others in use. ASG is set to send the mail to a server (we use Exchange ). Some providers block port 25, but usually on the outbound side to discourage running servers on the connection.
Example of what I use:
One of my mx records is set to use a dyndns record, so my destination route setting on Comodo looks like: mycompany.gotdns.com, then a separator “|” and port 25. My Exchange receive connector listens on ports 25, 587, and 2525; my firewall blocks any connection to those ports except for Comodo’s IP’s. It sound to me like you may be trying to connect with a mail client, not a server? If it is a server, use telnet to make sure you can make a connection to port 25. Here is one way:
Use Telnet to test SMTP communication: Exchange 2013 Help | Microsoft Learn
Pardon me if I misunderstood what you are looking for.

Lou

Hi,

Believe this was solved through the guys (and gals) at asgsupport@comodo.com. Please let us know if this is not the case.

Thank you,
Michel.