Defense+ not function properly and virus scanner won't run

I have exactly the same problem as the person in this thread:, but unfortunately the thread is closed so I have to make a new one.

I have followed each and every step described by the answers in that thread, and have, too, used revo uninstaller pro and Comodo System Cleaner before reinstalling, and these didn’t work either. The way this thread was solved was by re-downloading the installer, but I have tried this several times to no avail. Can anyone help?

First try the following. Uninstall CIS, reboot and then run this clean up tool.

Then disable all other security program that run in the background. Now try installing again.

Let us know if that helped or not.

What I did:

  • Uninstall CIS
  • Reboot
  • Run Comodo System Cleaner
  • Reboot
  • Run CIS Clean-up Utility
  • Reboot
  • Re-install CIS
  • Reboot

Still not working.

What version of CIS are you using? Check under Miscellaneous → About.

What other security programs do you have? Which ones are running in the background? Try disabling them.

When that doesn’t work try the following.

We are gonna take a look to see if there are some old drivers of your previously uninstalled security programs are still around. Go to Device Manager → View → show hidden devices → now look under Non Plug and Play drivers → when you see a driver that belongs to your previous security programs click right → uninstall —> reboot your computer.

When the problem persists make sure there are no auto starts from your previous security programs. Download Autoruns and run it.

This program finds about all auto starts in Windows. This tool can therefore seriously damage Windows when not handled properly. After starting go to Options and choose to hide Windows and Microsoft entries, to include empty locations and then push F5 to refresh.

Now check all entries to see if there are references to your previous security program. When you find them untick them. After unticking reboot your computer and see what happens.

I have no other security programs on top of whatever default stuff there is in Windows and Comodo, except a Firefox add-on, NoScript, which shouldn’t affect anything other than firefox since it isn’t stand-alone.

I previously had AVG, but there are no references to it in either device manager or autoruns.

EDIT: Oh, and I have version 3.14.129887.586, I assume that’s the latest because I re-downloaded the installer several times to make sure I wasn’t downloading a corrupt installer.

You might want to peek at the steps taken to solve this related issue:

All I got from that, was to check for updates to Windows. I just went on Microsoft Update, installed all updates, uninstalled Comodo, restarted, ran the clean-up script, restarted, installed Comodo, restarted, PROBLEMS ARE STILL THERE. I’m getting really frustrated now…

You may find useful my post at the end of

I attached a BAT script and was told BAT was forbidden,
I found everything was frozen - no edit, no nothing.
I did a select all and copy and started a new reply and pasted,
and because I was running very late I simply called it ZapBeta.txt.

If you download and rename to ZapBeta.BAT and run it, you will find that it does what the original script did at the beginning of the topic,
there is a vast amount of error checking / detection / reporting.
As a quick check, answer “N” to the first two options, i.e. LIST and KILL, then “Y” to “SHOW”, and it will tel you how many permissions issues are present.

The original script assumes that when it invokes DEL, RD, or REG.EXE, it will be obeyed.
Unfortunately Windows is NOT like that - it sometimes needs “pretty please”,
and often you will have to manually take ownership and overcome permission issues before Windows will let go.
My script will announce every item that fails to go away
and then YOU can focus on the problem.
It will even report if something cannot go because a process is using it.

My script is unlikely to fix permission issues, but it should identify exactly what needs fixing if there is such an issue.


Your script didn’t find any permissions problems. Either it doesn’t work or I don’t have any. I’ll try reinstalling CIS now, but I doubt it’ll work…

EDIT: sigh. It didn’t work. Any more ideas people?