Defense+ Issue: "... Not a Valid Win32 Application" [Merged Threads]

I’ve just installed CPF v3 on my system,
some Defense+ prompts that I’ve had no time to answer before disappearing,

and now each time I try to run something it is saying:
“…is not a valid Win32 application”

I can’t terminate the “CMDAgent” process,
neither uninstall comodo from the unistaller.

Any idea what the cause would be?

IDEA: I’ll try to boot in safe mode and stop Defense+

Okay now I’ve been able to uninstall it in safe mode (safe mode rules!),
and then now I’ve got my PC back, able to do stuff like web browsing (wow!) and opening applications.

I’m reinstalling it right now and if I get to find the cause of the problem I’ll let you know…

EDIT: hey mod thanks for the rename of my topic subject, the rules I had not read! (:SHY)

That error is usually caused by an app listed in explorer.exe D+ Policy Run an executable Blocked Applications Entry.

Go to Defense+\Advanced
Click Computer Security Policy
Find and select Explorer.exe
Click edit… button
Click Access Rights
Change Run an executable Settings

EDIT: added more infos

[attachment deleted by admin]

Okay I’ve studied your screenshot but where do you get the “Process Access Rig…” window?
I’ve looked almost everywhere in the Defense+ tab…

Can you be a little clearer on this?
Policy, then Run an executable…”

Then click modify.

thanks gibran,
now I was able to get there.

The problem may have been caused by this…
(I don’t know if it was there, because there wasn’t any way of running cfp.exe before uninstalling)

Still, I wonder how it could have gone there.
Thread closed, for now, as I hope nobody else encounters the same problems!


Since the installation of v3, I can not open anything (basically… except firefox)

I get this error (after a while… it’s very much delayed)

“program here” is not a valid Win32 application.

First discovered when trying to open msconfig in Run, It won’t open, after about 45 sec I get the popup

msconfig is not a valid Win32 application.

The same goes with cmd, services.msc, etc. Please help, this is hindering most of my computing here!! :slight_smile:

EDIT I’ve changed the setting on Defense+ and Firewall to Training (from Training w/ safe mode and Clean PC mode), and now they’re both ‘Learning’ as I successfully open aps :slight_smile:


I installed the new version 3 after I was prompted for an upgrade.
I had selected the highest security settings and custom setup.
Unfortunately after a few minutes i wasn’t able to open my browser giving an error message “not a valid win32 application” and one by one all my applications became inactive with the same message.
I tried to shutdown the machine and it gave me error message that I don’t have permission to do it.
I would like to uninstall the software and it won’t launch the unistaller as well giving the above error message.
Basicaly it has blocked all my access to my pc.
Should I try entering into safe mode and uninstalling it?


You’re not the only one - see my thread re. this.

Don’t know what I (we) did, but at least I had a cloned disk to use

*EDIT* I've changed the setting on Defense+ and Firewall to Training (from Training w/ safe mode and Clean PC mode), and now they're both 'Learning' as I successfully open aps

Doesnt help with Totalcmd (quicklunch link) or Miranda (XP links). Only Defense+/Image execution control settings/Disable helps. (:SAD)
And I’m still looking where stored app settings for “Allow/Deny” (for example when I choose Totalcmd as “executable/allow” - where I can change it?)

Go to Defense Plus → Advanced → Computer security policy. There you can view, change or delete the rules you set.

HELP! I installed V3 on prompting this morning. It was working fine until I tried to open an app I have to store passwords. I gave it permission but since that point every app I try to run the PC throws an alert box saying “xxxxx is not a valid Win32 application”.

This happens with EVERYTHING - from terminal to system restore and even V3 itself. My machine is effectively useless. I tried rebooting and restoring to the last know good point but it’s still doing it!!!

If anyone can help me get my machine back I’d REALLY appreciate the help…


Okay, panic over. Safe mode and then a system restore to yesterday fixed it. But I’m now very wary of upgrading again…

Thanks to anyone who was pondering this or typing a response as I post this update.

I’ve got this same problem. Is the only recourse to restore to an old backup point? I want to know what happened? Was it a choice I made during the firewall’s “learning”?


This just happened to me as well; I fixed it by uninstalling v3 from Safe Mode.

It started happening after I was asked to allow Total Commander to start.

Instead of accepting the default , I dropped down the box and chose the option with “win32” in the name.

Immediately after that, as others have said, no app whatever would start, all giving the “not a valid win32 app” message.

Upon trying to restart the box, none of my start up programs would load, and still no programs would start, so I went to safe mode, tried to re-enable totalcmd.exe as a trusted app in the Comodo dialogs, but this did not help.

I don’t have System Restore on, so uninstalling Comodo was my only apparent choice, after which all is normal.

I admit I did not really know what the “win32” option did, so it was my mistake to select it instead of the default, but it is surely a bug that a single misclick can have such drastic consequences!

Thanks for listening…


Thanks for your reply giraffe. I managed to unistall it through safe mode (it could have been worse leaving residues behind, however it got rid off the whole thing) (:KWL). I re-installed the old version as I was quite familiar with it. :BNC

Well, as was often the case in my childhood, I learned a valuable lesson the hard way. Install v3 of Firewall without Defense+ (I’ve decided to just keep using BOClean for anti-mailware). It was the only way could upgrade without causing my system to tell me that none of my apps were valid Win32 apps. Also, when the learning mode popup displays, always just choose allow with remember checked (if you know and trust the app/component); don’t choose anything from the drop-down list. So far, doing these things has allowed my most recent attempt to upgrade the firewall to actually work for more than 5 minutes.


Wow, I am SO glad I didn’t upgrade when I got the prompt this morning. Clearly version 3 isn’t ready for the masses. I’ll stick with version 2.4 for now but if I have to find (and pay for) a stable firewall then I’ll do so. Reading the posts here doesn’t give me any confidence in the new version.

i had the same prob,the way i resolved thie issue was…went into defence+>predefined security policies,then edited my windows\system 32 policy to window system application then applied it …was able to access after doing that

Same problem here - it’s Defense+
Disable it and all your apps should work again.

I had mine set to “Train with Safe Mode” and worked ok for a while, but then locked me out of everything.

Disabled and all ok - at the moment have reset and now running in “Clean PC Mode”, seems to be ok at the moment.

Have to say it’s not a good start - the 64-bit Vista beta was more stable/less trouble than this release !!