Defense+ crashes Microsoft VS Debugger [Issue Report]

Defense+ crashes Microsoft VS Debugger

The bug/issue

  1. What you did: In Visual Studio, I started to debug my ASP.NET MVC Application.
  2. What actually happened or you actually saw: The debugger did not launch, it crashed due to a page fault caused by guard64.dll.
  3. What you expected to happen or see: The debugger should launch.
  4. How you tried to fix it & what happened: Various attempts. Disabling Comodo+/AppInit_DLLs fixed it.
  5. If its an application compatibility problem have you tried the application fixes here?: It’s not.
  6. Details & exact version of any application (execpt CIS) involved with download link: MS VS 2010 SP1
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: Run MS VS 2010 SP1, create a Web Project and start debugging.
  8. Any other information (eg your guess regarding the cause, with reasons):
    My Visual Studio failed to start the debugger for some days with a pretty generic error.
    After trying out suggestions to fix this on the internet I decided to go through the whole stack.

And apparently, I see that msvsmon.exe suddenly crashes due to a page fault.
Before that point, there were a lot of guard64.sys related calls, which is your appinit dll hook.

Disabling Defense+ and emptying the appinit_dlls in the registry solved that problem.
But now I don’t have Defense+, can you fix this for me or I can exclude msvsmon.exe?

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug: Not necessary.
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List: None found.
  3. A CIS config report or file: Not related to this issue.
  4. Crash or freeze dump file: None, the debugger just quits. And my trace isn’t detailed enough, i.e. it doesn’t contain addresses nor parameters for guard64.dll calls…

Your set-up

  1. CIS version, AV database version & configuration used: 5.4.189068.1354
  2. a) Have you updated (without uninstall) from CIS 3 or 4: No.
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS: No.
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): No.
  5. Defense+, Sandbox, Firewall & AV security levels: D+= Safe , Sandbox= Safe, Firewall = Safe, AV = Safe
  6. OS version, service pack, number of bits, UAC setting, & account type: Windows 7 Pro SP1 x64, UAC on, Admin
  7. Other security and utility software installed: Micosoft Security Essentials, unrelated to this issue.
  8. Virtual machine used (Please do NOT use Virtual box): No.

We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation


Updated my issue report to your format, although it takes more time as it now includes a lot of irrelevant information. The original content can be found under bullet 8…

Thank you for your Issue report.

Moved to verified.

Thank you


This FAQ may help here.

Best wishes