Defence+ and games from reflexive bug

I’ll keep it short. go to download and install any game (they are free trials) then start the game, you’ll see a screen with bunch of screenshots and buttons like play now, buy now etc (I call it wrapper). Anyway press “play now” and… that’s it, the “wrapper” screen goes away and nothing happens. Nothing in the logs, add entire game folder in trusted files, still nothing, Training mode - same effect. In defence+ options check “disable Defence+ completly” (and restart) game’s working fine. Win 7 x64 (maybe it’s OS specific bug) .

Since there are no reply, are you guys implying that they run fine on your system with defence+ ?

Did you enable the sandbox?

It looks like sandboxes fault, because trainings mode doesnt solve it, but disabling does. Try to disable only the sandbox to find out.

The most games there have a price tag of “from 6,99”.
You could get much better games for that price on (christmas) sales in “different online stores or game services”.

I tried disabling the sandbox and I tried turning off and disabling every possible option in Defence+ setting window, situation did not change.

Here’s setup file for the game I’m having this problem with

It’s one of Reflexive’s older games (trial) you can download and see for yourself. It installs fine but doesn’t go past the “wrapper” screen (it just disappears).

I know examples of games with a specific anti cheat software, which refuse to let you play while defense+ was enabled. You had to fully reboot-disable it first.

Maybe your game has a “game protection”, its a trial.
Or an anti cheat for example.

Is the “wrapper” screen related to connections to the internet? Maybe thats blocked.

It can use the internet to unlock the game if you buy it, but there are offline activation options too.

I’m not sure how you cheat in a chess game, but I guess it can be anti-cheat system present in all reflexive gaes since they all have this problem. So it may be same situation it was with GameGuard, weird thing is, then, that nor the game nor Defence+ log shows any error(s).

Because the security software would be fine with the game. So the logs of it are empty.

I didnt like such “super self protecting” free-trial ware. Have they taken as much strength into clean up after un-install? :smiley:

When the logs are empty, and the sandbox does not insert the game, theres not much that you can do in the settings of your security program. Its not the reason then. Apart from a scenario where you gave a wrong answer to a question before. And this wasnt set to be logged.

Correct me if i am wrong :slight_smile:

Try adding it to the Exclusions of Detect Shellcode injections (i.e. Buffer overflow protection) and see if that prevents it from crashing silently.

Edit: I installed it on my Win 7 SP1 x86. When I first started it I got a message it was sandboxed, I told CIS not to sandbox it next time, I closed it, opened it and it worked.