Defence+ and "Access Memory"

My Defence+ is still blocking a program I have set as trusted to access memory.
I have also done what was suggested in the FAQ - “choose Edit ~ Customise ~ Protection settings ~ Interprocess Memory Accesses ~ Modify and add the file to the exclusion list.”

Any ideas?


hey and warm welcome to comodo forums!

CIS → Defense+ → Computer Security Policy → select Comodo Internet Securiy and press edit → Customize -->Access Right → Modify → Add

Exclusion list
CIS —> Defense+ —> Defense+ Settings —> Execution control Settings —> Detect shellcode injections (i.e. Buffer overflow protection) —> Exclusions —> Add —> Browse…

Will this help?

Valentin N

Did you selected COMODO Internet Security in Defense+ Rules tab before you pressed Edit button? Also, make sure that Interprocess Memory Accesses is set to Active.

Thank you both,

The problem is now fixed

I’m also having this same problem. I have a program (Program Files\System Explorer\systemexplorer.exe). I have made all the changes mentioned here, but CIS Firewall/Defense+ still says “Defense+ has blocked xxx intrusions so far”. The number continues to increment until I exit the application, then it stops. It starts again as soon as I startup the application again. By the way, the target listed in Defense! Events is
Program Files\Comodo\Comodo Internet Security\cmdagent.exe

Any other ideas how to fix this? I’m running WinXP Pro SP3 and Comodo Firewall 5.3.181415.1237.

Tks for any help.

Please, make sure you’ve done exactly this: go to Defense+ tab → Computer Security Policy → scroll down to the COMODO Internet Security and select it → Edit → Customize → Protection Settings tab → Interprocess Memory Accesses must be set to Active and click on Modify → Add → now use Running Processes or Browse option and find systemexplorer.exe → Apply the changes.

Fantastic deadman! ;D It works!! I’ve been playing with different settings for the last 3 days.
Thanks so much for your help!