Debuggers not working after uninstall

Hello! I have a problem with CIS(Defence+).
I installed CIS some time ago, but uninstalled(from Control Panel and then clean-up tool) it because I couldn’t use gdb.exe (FreePascal compiler). The problem persists, and I can’t use neither GCC from CobeBlocks(installed after CIS). I know this is not a new problem, but it didn’t disappear after uninstall.
Do you have a solution?

Sorry you are having this problem. Debuggers work at a very low level and therefore create unique problems for security tools.

You could start here. Not a complete solution for GDB I think, but at least a starting point.

Please do tell us if you can resolve the issue so we can help others.

Best wishes


I’m curious as all get-out here. ???

Just what is not workin’? What version your CIS, what your config and what your behavior settings? Hmmm? ???

Are you sure that GDB and GCC were insalled properly? Because you say that its ‘not working’ even w/out CIS present. Its plausible that the init instalation of these utility apps got horked becasue CIS blocked something during install. On my system VS 2008 & SQL server, Java SDK and all that noneense were installed Apr 2010. And one has to jump through freakin’ hoops to get all that to work properly. It takes lliterally hours. I don’t believe either GDB nor GCC worm their way as deeply into Windows as does the MS utilitarian apps aforementioned. I believe that I 'd installed all of that prior to CIS. My current CIS installation folder is date 11 Apr 16.

So removing CIS, & your SDK’s should be gutenuff.

Throw CCleaner & System File checker at the problem (after de-installation). If, after that, the stock install of either GDB or GCC don’t ‘work’ - whatever that means - then you have a much deeper prollem (and its not related to CIS). Yep.

But if it does work, then that’s good. Right? I always have liked ‘works now’. If it does ‘works now’, then install CIS and let ‘er loose. You should get alerts on what he’s complainin’ 'bout concerning GDB or GCC.

Get back with us, ay?
(CNY) And us developers needs ya too (Yep)

Thanks for fast answers.
I’m not at my computer right now. And I don’t know if I’ll be online next days, so I think some more details would be useful:
I use Windows 7 x64. Free Pascal was installed first, with no problem. Then I installed CIS Pro(1 year free), but cancelled install, and installed Firewall instead. But, surprise surprise, the UI shows “Comodo Internet Security”. And Free Pascal degugger/compiler doesn’t work(can’t create executabile file, but rarely it works. Strange!). I has this problem in the past(before HDD format), so I just uninstalled the product, then run clean-up tool twice+reboots(one question: why does the clean-up tool delete the product files and then stop blocking services?). However, it didn’t find anything. Pascal still not working after reinstall(one note: I copied the main EXE from the previous install, because of having problems with resolution). Then installed CodeBlocks(C++), but it can’t use MinGW GCC degugger, so I installed it manually(here it might not be Comodo’s problem). It works, but Pascal can’t create EXEs anymore.
It’s strange that I could sometimes compile/debug/run programs in pascal normally, but then have error in file creation. I will try so a CClean and sfc.
Thank you very much, and I hope we can solve this out, and sorry if I missed something important.

I am not familiar with working with debuggers. There is one topic in the D+/Sandbox FAQ that could be interesting: Comodo Forum.

Try with giving the debugging programs the Installer/Updater policy. That will allow them to start various sub processes.

After you made the rule in Defense + Rules you will see the rule somewhere under a rule called All Applications. You need to drag and drop the rules you made to a place above the All Applications rule.

The problem is that I haven’t any Comodo product installed, but the problem is still going on.
Perhaps a screenshot may help.

[attachment deleted by admin]

I now see the topic title says “after uninstall”.

Try running this cleanup tool in Safe Mode. That is the best way to make sure it removes everything CIS related.

You said you’re running Win 7 x64, and yet your screenshot shows Win32 for i386. Are you on i386 platform running Win7 64-bit? Hmmmm. That may be an issue with respet to Windows on Windows (or 32-bit emulation in 64-bit OS).

If you’re running on x68-64 then you need v2.4.0 or better of Free Pascal. Neverthess, it doesn’t appear that there’s a version compatible w/Win 7:

That notwithstanding, it appears there is an issue related to Code::Blocks and the C++ compiler that’s installed:

Moreover, I don’t know if the compiler and the IDE are serparate components of Pascal either. In any case, once you’ve uninstalled CIS, there should be no impediment to the functionality of your SDKs. If you can’t get either to work w/out CIS installed - especially not with only CIS firewall installed - the root cause pertains to installation of the compiler / IDE’s in question.

This is the trouble. Free Pascal doesn’t have IDE for x64, only compiler, and the x86 has resolution problems. They can be fixed, but it’s a big pain. CodeBlocks works fine now. I will come back after sfc and uninstall tool running.

I finally fixed it with pascal. I just had to copy GDB from the new MinGW instalation to the Free Pascal dir. So it wasn’t Comodo’s fault, and I apologise for this. Thank you for help!

No problem. Your findings may still be helpful for somebody else.