Database update failed:no internet connection but this is not true! (SOLVED)

CAVL is giving me a strange message whenever I try to update my database. It says to check my internet connection, but I do have internet as I can surf with Firefox. What’s going on? Is the server down???

Anybodyelse with the same problem? Is my installation corrupted??

Finally solved problem.
Got Ubuntu and Vista on dual boot. Updated Comodo to latest database version on Vista. Then rebooted on Ubuntu and opened terminal:
sudo nautilus
copied the b0021088.cav file from C:/PROGRAM FILE/COMODO/SCANNERS to OPT/COMODO/SCANNERS in ubuntu then renamed bases.cav to basesold.cav and the copied file b0021088.cav was just renamed bases.cav again. Rebooted linux. Runned a diagnostic for Comodo, rebooted linux again. Now it seems to update normally and I have the latest version. Question: why do we need cav-linux if the databaseversion is for Windows and the cav-linux database is then only specific to linux??? :wink:

SOLVED? :smiley:
My CAVL continously deny the update. No internet connection… What’s up COMODO? Server is down?

There is one database version that blocks. You have to download and install manually the latest version to your COMODO/scanner folder, then reboot. Follow carefully instructions in my latest post. I used Windows, since I’m on dual boot, and copied/paste in Ubuntu folder then renamed .

Good Idea, but how should i do the alternative download on a single boot installation with Linux Mint 13 Maya 32 Bit and Comodo continously denying the update since last Thursday.
After the last Mint Update to Kernel even the file filter system driver can’t be loaded. So Comodo still does not run properly.

Try downloading latest windows database from here: Comodo Anti Malware Database Latest Version & Additions 2022
I was told both linux and Windows databases were the same. Download it to a place like desktop or download folder. Then run terminal sudo nautilus, then enter password, then rename your file the way I renamed mine adjusting for the current database version and place it to the correct folder in /OPT/COMODO/SCANNER. Should work! :wink:

N.B.: If you run only Mint or Linux, then you really don’t need an AV. There are only very tiny chances of getting viruses on linux I was told…!

thanks gdiloren,
but this only solves one of my comodo problems.
after updating mint to kernel cannot finish installation properly.
seems that redirfs.ko ist not found. (full messages in my other posting)
the last terminal message means:

FATAL: Module redirfs not found.

any idea what solves this problem?!

ps: yes i know, linux is not the main target for viruses, but it´s not completely save: Kommentar: Der erste gefährliche Linux-Virus kommt | heise online
nothing is save, when you´re using the internet…

Here are my results. After downloading the latest bases.cav and copied it as sudo into opt/comodo/scanners and restarted the system nothing is working anymore.
After retrying to update for the last definition files comodo tells me:

Failed: scanner is busy with another scanning task right now. please wait until it is completed.

But nothing has been started?!

I think it all depends on the missing redirfs.ko in kernel modul.
…and the kernel is not compatible with comodo.

because of this thread is already marked solved i continue in my other posting.


Do not download updated anti-virus database. Reaches 46% and gives an error.

What is the reason?

[attachment deleted by admin]

hi megaherz,
same on my system.
but your comodo is still running or not? yellow shield…
just try workaround from gdiloren in this thread.
seems to be a corrupt .cav file that stops update at 46-47%


Сomodo running, but the database is not updated. Download from the base and replaced the file shows the version of 21015 and not 21199.

Launched the “Diagnostics”, no errors were found.

[attachment deleted by admin]