cygwin [Resolved]

I seem to have a similar problem with cygwin and CIS/Sandbox as reported in another post.

I followed the hint in that post and added cygwin’s bash.exe to D+'s CSP as an “Installer or Updater”. Problem is that I start cygwin via a small bat file containing nothing but

[at]echo off
chdir C:\cygwin\bin
bash --login -i

It opens a cmd window and executes bash, that’s all. Since I installed CIS 4 this morning, I get the following error message in the cmd window that duly opens:
C:\cygwin\bin\bash.exe: *** fatal error - couln’t allocate heap, Win32 error 487, base 0x…

Even adding cmd.exe as an Installer/Updater (probably not a good idea) did not do the trick.

Can someone help me?

Did you try to add the batch to “Safe Files” that should get the batch out of the sandbox and also prevent bash.exe from getting sandboxed, because if an untrusted program get’s sandboxed all things it starts will also be sandboxed…

Thanx for the prompt reply.

Did you try to add the batch to “Safe Files” that should get the batch out of the sandbox?

Yes, I did, same behaviour. Will do a reboot to be sure. Btw, am running Vista SP2 with CIS downloaded this morning (D* is in Safe Mode).

Will try a reinstall of cygwin, but not just yet.

So you still receive a sandbox alert when you run the batch after first reboot?

Reinstalling Cygwin won’t help, this should have worked, i think you hit a bug.
Can you try to put the batch file on the sandbox manually and set it to the lowest level of protection possible?

See if that helps any?

Sorry, I did not make myself understood. The cygwin problem remains, but CIS no longer complaints/notifies about sandboxing the app.

I have just updated my cygwin installation to the latest 1.7 (should now be ok), but still get similar errors when executing the batch file and then issuing commands like ls or gcc: see attached screen shot.

As for CIS, I have the batch file as a safe file and bash.exe as an Installer/Updater in D+ → Advanced.

What else can I try?

[attachment deleted by admin]

You’ll probably only receive the Sandbox alert once after reboot, so you’ll probably have to boot fresh to see it again, if that still doesn’t solve the issue, try to disable the sandbox for a moment and see if all works fine then.

If it does I can only think of putting the batch file on CPS also as installer and remove it from Trusted Files, also make sure it’s not on the “pending files” list…

Just to add a recent discovery - making something an ‘installer-updater’ does not work unless ‘automatically detect installers/updaters’ is ticked under sandbox settings.

Best wishes


“Automatically detect” is ticked, no change.

I have now rebooted, to no avail. But maybe it is not CIS’ fault, at least it does not indicate sandboxing. Also added cygwin1.dll to the Installer/Updater list, still no change.

Am clueless as to what is causing cygwin to behave in this way. All I can say is that it worked well with CIS 3. Noticed that CIS4 takes forever to initialize after a reboot. Is that normal?

Best, akorn

cygwin can’t work, even disable Comodo Personal Firewall.
tried disable the service of Comodo Internet Security Helper Service, however, i failed.

i wonder what the Comodo do?


Can you post the source link where you got cygwin from, I’ll see if I can test this with CIS 5/2011 when the beta is released (according to planning today)…

I always take the latest setup.exe from and then choose an ftp site (e.g. to install all I need.


Yes. i got setup.exe from too. URL and setting as follow:

-Cygwin Installation
-any setting of setup.exe is default.

Comodo Internet Security Premium configuration:
-Version, 4.1.150349.920/free
-Disabled, Sandbox Security Level
-Disabled, Defense+ Security Level
-Disabled, Antivirus Security Level

-Safe Mode, Firewall Security Level

Best Regards,

Same proiblem. I killed the Comodo service manually. Problem disappear.

Before I tried to uninstall, install: problem is absent, problem come back after Comodo service starts.

All under Windows Vista 32 bits, updated, running only the firewall service, Comodo 4, on my home notebook, used as a testbed for the upgrade from version 3 to version 4.

A serious problem for any cygwin user: I’ve many Windows machine, XP and Vista, running Comodo 3 and cygwin. I don’t think I’m going to update before the problem is solved.


Just tested this on the BETA version 5 and it works fine, so you can join the BETA testing program or have to wait till the final release of CIS 2011 (v5.x) :wink:

They won’t fix this on previous versions

I’m completely satisfied from v3. so I think I’m going to stay and wait for v5. Orfheo.

Okay now after updating Version 5.0+. thanks for Comodo. :slight_smile:

Thanks for keeping us informed.