Cut and paste doesn't work (VMWare Workstation 9) [V6][M873]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?: Always
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    a: Installed Comodo Firewall (the firewall-only version that comes with HIPS). Cut and paste between the host and the guest stopped working in my VMWare XP SP3 x86 guest.
  • If not obvious, what U expected to happen: Expected Cut and Paste to continue working between host and guest. I should just be able to add an exception (which I did) and that should work (it doesn’t).
  • If a software compatibility problem have U tried the conflict FAQ?: No, where is it?
  • Any software except CIS/OS involved? If so - name, & exact version: VMWare Tools Daemon v9.2.4 build-1398046
  • Any other information, eg your guess at the cause, how U tried to fix it etc: I have tried everything including disabling both the Firewall and HIPS. Still there is absolutely no difference. The only solution is to uninstall Comodo Firewall.
    I am also experiencing vmtoolsd CPU spikes and hanging on shutdown. At the request of the moderator I have split that off into a separate issue:
    VM XP guest: Continual cpu spikes and hanging in vmtoolsd - Bug Reports - CIS
    Please note I am running Comodo Firewall --same version but x64-- on a Windows 7 x64 guest and I am able to cut and paste.

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration: 6.3.302093.2976, Firewall only version (Firewall+HIPS). Default and disabled tried.

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: Doesn’t matter
  • Have U made any other changes to the default config? (egs here.): Yeah I tried to add vmtoolsd after cut and paste stopped working but it didn’t make a difference.
  • Have U updated (without uninstall) from a CIS 5?: No
    [li]if so, have U tried a a clean reinstall - if not please do?: Not relevant
    [/li]- Have U imported a config from a previous version of CIS: No
    [li]if so, have U tried a standard config - if not please do: No
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used: I installed Comodo Firewall-only version 6.3.302093.2976 on Windows XP SP3 x86, running as a VMWare Workstation 9 guest OS. My host is Windows 7 SP1 x64.
  • Other security/s’box software a) currently installed b) installed since OS: a=none b=none

Comodo diagnostic file attached.

[attachment deleted by admin]

Just to be clear, does this issue still exist if you disable the Firewall, HIPS, and Auto-Sandbox and then restart the computer?

I can’t figure out how to quote you in my post. The answer to your question is yes. Just now I tried again. Firewall, HIPS and sandbox disabled, reboot, confirm still disabled, copy and paste still doesn’t work between the host and the guest.

About your quote question, there should be a button for quote on each of the posts. To quote a post you use that button. It will then insert the quote in your reply.

Also, do the CPU spikes also continue if the above-mentioned components are disabled?
If so, what if you also disable the AV component and restart the computer?

Thank you.

What is happening is your forum is logging me out and I have to login each time I visit it. I don’t know if that is the way it’s supposed to be. Most forums keep you logged in. Without being logged in there is no quote button, which is why I didn’t see it. For example I had to login to make this post even though I previously logged in less than two hours ago.


There is no AV component, I downloaded the Firewall only version. It comes with HIPS and Sandbox but no AV.

Thanks for helping I appreciate it.

There are two ways to log in. The one at the upper right will only keep you logged in temporarily. However, there is also one which can be accessed through the login section in the bar which runs across the top of the page. On that page there is an optional checkbox which will allow you to stay logged in.

Thank you. To me this sounds like there are two different issues going on. Please check the Defense+ logs and see if there is anything from VMware which is periodically being blocked. If Comodo Firewall is blocking something every 30 seconds I would assume we can see it in the logs as well. If you can find it in the logs please attach a screenshot of a relevant part in your next reply.

Thank you.

Ok, thanks, I did that, maybe it will help. I suggest adding that always logged in option to the temporary login at the upper right. Had you not said anything I wouldn’t have had any idea.

There is nothing in the logs about vmtoolsd, and also as I mentioned I can still observe the behavior even when all Comodo components are disabled.

About adding the option to stay in to the one in the upper right corner, I agree with you. I don’t know why they haven’t added that. It would be helpful. Also, I should make it clear that I do not work for Comodo. I am a volunteer moderator who has volunteered to handle the bug reporting. I try to make sure everything has been checked and that everything needed is included before they are sent to the devs. However, I am not Comodo staff and have absolutely no control over the product or the coding for the forum.

During the time you are experiencing the spikes in CPU, if you open the main Comodo Firewall GUI do you see that the Defense+ Blocked Intrusions count is increasing. I am assuming that this is likely caused by Comodo Firewall preventing it from accessing some of the protected files and folders. This would explain the repetitive nature of it as VMware would continually try to access the file unsuccessfully, and Comodo would block it. Then after a set period of time (30s) it tries again. If that is the case then this is not a bug, but just a byproduct of how Comodo Firewall works. If you wish you can probably get around this by adding the files in question to the Behavioral Blocker exclusions.

Also, about cut and paste not working correctly, are you sure that it works correctly if Comodo Firewall is removed? I ask this to rule out the possibility that it is caused by another program, or by some minor change which has been made to the system or other programs.

Thank you.

That’s very nice of you, I hope they’re giving you free product :slight_smile:

No, there are no events in Firewall or HIPS that correlate. As I mentioned this happens even when all modules are disabled. Also, when try to I restart or shutdown the vm it hangs on vmtoolsd.exe saying it’s not responding.

Yes, I uninstalled Comodo and it works again and the spikes in vmtoolsd are gone. Every 30 seconds now vmtoolsd has some IO interaction. I’m guessing this is what was blocked by Comodo.

Okay, as I said before, it sounds to me like there are two issues here. There is the cut and paste issue and there is the hang/CPU issues from VMWare. However, only one issue can be forwarded from each report.

Thus, here is what I would recommend. Please edit the first post of this report such that it is only talking about the cut and paste issue. However, the issue with the hang/CPU problems should be noted as additional information. Then, when you are done with that, copy and paste the code in the first post. Then create a second bug reporting topic and paste in the code. Then edit this so that it is talking about the hang/CPU issue, but mentioning the cut and paste problem as additional information.

Once that is done reply to this post. I can then forward both to the devs.

Thank you.

Ok I have separated the problem into two issues, each with its own post. You can find the other issue here:
VM XP guest: Continual cpu spikes and hanging in vmtoolsd - Bug Reports - CIS

Thank you. I have edited your first post so that it is now entirely in the required format, which is preferred by the devs. Please look it over and make sure that I did not make any mistakes while moving the information around. Once you let me know it’s fine I will forward this to the devs.

Thank you.

It’s fine. Thanks again.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

Can you please check and see if this is fixed with the newest version (7.0.313494.4115)? Please respond to this topic letting us know whether it is fixed or if you are still experiencing the problem.

Thank you.

PM sent.

This is fixed in version 7.0.313494.4115. Thanks for your help and thanks to the developers for fixing it!

Thank you for checking this. I have closed the entry in the tracker and will move this report to Resolved. Let me know if the issue returns.

Thanks again.