CTM Still Not Ready....

I tried CTM again last night and it’s still a disaster upon attempted un-install. I was up until 2:30AM trying to get past BSOD. Even after I “un-installed” it, it was still present on reboot, then today it just…disappeared. ??? It was a bit funny though, CTM was the only thing that would allow my PC to reboot to allow me to fix the problem. It’s funny now, it wasn’t very funny at 2AM. 88)

CTM is a bug ridden POS. They know it screws up PC’s, but they still offering it.

Guess it really has a time machine inside ;D Even so also a (comodo) time bomb :frowning:

The whole thing is just mystifying. It won’t install right, it doesn’t work after it does install, and you can’t un-install it. It nukes the very information that it’s supposed to protect. It just doesn’t work at any juncture for many people. It apparently works like a charm for some people…it’s equal parts maddening and hilarious! ;D

CTM sounds like a woman to me ;D

To be honest, I do nut understand why comodo still has CTM on there download page. They know about all the problems and they are risking damage claims by keeping it there. Try, on install you need to accept the agreement, but That is for the product and for the functionality of the product. It’s clear for everybody that comodo is aware of the CTM bug and they are aware that CTM can seriously harm a computer. This makes them guilty of negligence. This means that a damage claim for any harm caused by CTM will stand in court. I already did inform comodo about this for few weeks back and adviced them to remove the CTM downloadable to safe there ass, but they did not.

Now let us see how fast they will remove this post!